Hello Guest it is June 16, 2019, 05:39:55 PM

Author Topic: How to make soft limits stay on in Mach3  (Read 8566 times)

0 Members and 1 Guest are viewing this topic.

How to make soft limits stay on in Mach3
« on: July 24, 2012, 12:09:16 PM »
I am running a CNC router with Mach 3. To prevent step errors from accumulating, I hit "All Home" after each sheet is cut and the program returns home (program home, not hardware home). But here's the problem, I have to hit "All Home" twice each time because the first time turns soft limits off, the second time turns soft limits back on.  Or, I can manually turn the soft limits back on after "All Home" turns them off.  But why turn them off to begin with? It just costs extra steps. If you forget the step and don't turn soft limits back on, then you can crash the limit switches when jogging for setups, tool changes etc. Crashing the limit switches is big trouble on this machine... and its inevitable when soft limits is always toggling off!

Is there no way to make soft limits stay on until you ask them turn off?

Any suggestions would be greatly appreciated!

Thanks, tlbokc

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: How to make soft limits stay on in Mach3
« Reply #1 on: July 24, 2012, 01:26:53 PM »
Do you have home switches?
I am just a bit confused by this bit "I hit "All Home" after each sheet is cut and the program returns home (program home, not hardware home). " If you have Home switches then the axis will move to them and set the machine coords when you press Ref All.

Soft limits never get turned off on any of my machines so not sure whats going on with yours.
If you attach your xml I will have a look and see if I can replicate and find the issue.
Hood
Re: How to make soft limits stay on in Mach3
« Reply #2 on: July 24, 2012, 02:04:12 PM »
This CNC router is running stepper motors without encoders, so when it misses a step, and it does miss steps, then it looses a little position. Each time I run the program, the program goes to "Zero" and rewinds. The program Zero is now flawed because of missed steps. So, before loading and running a new sheet I hit "Ref All Home" to reset the carriage to the machine limit switches.  When I do, the Mach3 refinds the XYZ limit switches as it should BUT turns OFF soft limits. If I hit "Ref All Home" again, it refinds the XYZ limit switches and turns ON soft limits. Every time I hit "Ref All Home" it toggles the soft limits.  (Just like pressing the soft limits button: press on, press off, press on, press off etc.)

Why can't the soft limits remain on until I turn them off?  Is there a preference setting that keeps them from toggleing on and off each time I use "Ref All Home?" 

Besides the extra wear on the machine, there is the constant opportunity to crash the switches when soft limits turns off automatically and the operator fails to notice it.

Thanks, tlbokc

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: How to make soft limits stay on in Mach3
« Reply #3 on: July 24, 2012, 02:06:46 PM »
As I said softlimits never turn off for me so it is likely an issue in your config, attach your xml and I will look.
Hood

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: How to make soft limits stay on in Mach3
« Reply #4 on: July 24, 2012, 02:12:04 PM »
Also worth mentioning is if your steppers are losing position then they are either under sized for your machine or you have binding axis or you are trying to drive them too fast or possibly even you have a bad pulse.
I have steppers on the coil winder and previously had them on the Bridgeport and never once lost steps unless I crashed an axis or similar.
Hood
Re: How to make soft limits stay on in Mach3
« Reply #5 on: July 24, 2012, 02:13:20 PM »
or maybe a custom screen. ?
be interesting to see what is under that button.

Offline BR549

*
  •  6,871 6,871
    • View Profile
Re: How to make soft limits stay on in Mach3
« Reply #6 on: July 24, 2012, 02:14:41 PM »
That would be my question WHAT code is under that button(;-) THis is the stock 1024 button code

DoButton( 24 )
DoButton( 23 )
DoButton( 22 )
DoButton( 25 )

DoOEMButton(133)
DoOEMButton(134)
DoOEMButton(135)
 


(;-) TP
« Last Edit: July 24, 2012, 02:19:35 PM by BR549 »
Re: How to make soft limits stay on in Mach3
« Reply #7 on: July 24, 2012, 03:22:46 PM »
Sorry, don't know what an XML file is. How to find it?  I have a text file that is the router program. Is the XML an export from Mach 3?

Thanks,  tlbokc
Re: How to make soft limits stay on in Mach3
« Reply #8 on: July 24, 2012, 03:35:41 PM »
Regarding the stepper motors: the problem is in the drive system. It is rather crude... a rack and pinion with the pinion spring loaded into the rack gear... runs dry.  Even with dry film lube the gears are galling each other and bind. Further, the carriage guide system is dual vee bearings  running on an angle iron track. The carriage long axis is driven by two steppers, one one each side, running in unison.  The carriage guide system runs in slight arcs, binding one motor against the other. When the tension gets too high, one motor must slip a few steps. This usually happens once each direction of travel along the long axis when cutting a 48" x 96" sheet.  I can't fix this problem without buying a better machine.  It's just not a good design.

Thanks, tlbokc

Offline BR549

*
  •  6,871 6,871
    • View Profile
Re: How to make soft limits stay on in Mach3
« Reply #9 on: July 24, 2012, 03:44:58 PM »
Sure you can fix it just take the time to realign the angles to run with each other and set the pinion to run with a light preloading.

(;-) TP