Hello Guest it is February 26, 2024, 07:12:26 AM

Author Topic: Was working but suddenly quit  (Read 2287 times)

0 Members and 1 Guest are viewing this topic.

Was working but suddenly quit
« on: July 24, 2012, 09:25:52 PM »
I setup a new computer for CNC exclusively for 3 axis mill (I tried a Dell with intigrated video and will not work for Mach 3). I am running version R1.83.027 (I bought 6 years ago before heart attack). The specs are much more than required - 3.2G CPU, 2G ram, 1333 buss, AGP video, SMART Hard drive at 7200 RPM.
I set the ports and motor run and everything was sweet using a 0.5000 mill, except it didn't compensate for mill diameter - I added markers to the motors and it ran absolute dimensions without compensating for mill diameter (I am benchtesting before installing). I checked the tool table and verified mill dimensions and wear dimensions, then tried to use a 0.625 mill which I will be using, and it would not accept the tool info at all, and now nothing works - no jog when I use TAB key to bring up the display, and the keyboard arrows and PG up/Pg dn is not operating the motors either, which all was working before. - numbers move in the display but motors do not. There is a signal to the BOB but no CNC control or step signal.
I tried to install the demo to try it and the same problem. Did I make a mistake adding the new demo in addition to the 1.83.027 version??
Would I need to format the hard drive to correct the printer port problem, or are there other problems????
I am East of Pittsburgh PA. Anyone near by??

Offline Tweakie.CNC

  • *
  •  9,189 9,189
  • Super Kitty
    • View Profile
Re: Was working but suddenly quit
« Reply #1 on: July 25, 2012, 02:01:19 AM »
Hi Cole,

Perhaps the first thing to check is that your parallel port (I assume you are using Port#1) is enabled and set to the correct address (usually 0x038) in Config, Ports & Pins. Then check all your electrical connections including the parallel port cable for continuity etc.
At switch-on your motors should lock position - if they do not, then check your power supply voltage to the drivers.

Coming back to Config, Ports & Pins - check Motor Outputs are enabled and the step / direction pins and port are correctly specified.

Get the machine running first then worry about the tool radius compensation issue second.

Hope this helps,