Hello Guest it is October 14, 2019, 02:30:30 AM

Author Topic: Not returning to zero  (Read 12902 times)

0 Members and 1 Guest are viewing this topic.

Offline Greolt

*
  •  956 956
    • View Profile
Not returning to zero
« on: January 14, 2007, 11:49:02 PM »
Disabling legacy mode in bios has made comunication more stable.

However I have a funny problem.

Set all DROs to zero, run the roadrunner, DROs not ending on zero.  Gcode last move is go to zero but DROs not returning to zero.

Watching the Z axis DRO during code execution. Z spends most of the time at -0.1 and goes up for rapids returning to -0.1

Each time (or most) it returns 0.0025 different than the last. So they add up to a cumulative error by the end.

See pic for screen capture at the end of roadrunner execution.
« Last Edit: January 15, 2007, 12:07:39 AM by Greolt »

Offline rcrabb

*
  •  146 146
    • View Profile
Re: Not returning to zero
« Reply #1 on: January 15, 2007, 12:02:37 AM »
I only ran the roadrunner a few time since I got the comuncations fixed. I noticed the same thing with the Z positioning and returning to zero.
Ryan

Offline Greolt

*
  •  956 956
    • View Profile
Re: Not returning to zero
« Reply #2 on: January 15, 2007, 12:15:47 AM »
Glad it is not just me.

It always feels better if someone else is having the same problem.  ;D

Offline kookaburra

*
  •  56 56
  • Fussy? Yep! That's Me ;)
    • View Profile
    • Akela Website
Re: Not returning to zero
« Reply #3 on: January 15, 2007, 01:00:11 AM »
Beta Team,

Art is aware of this issue and at the moment is talking with the Pod developer about it. The Pod and Mach 3 is accurate to +/- 1 step (provided you have the latest version of Mach 3 and the Pod firmware update). I will re-visit this with Art to get an update on his thoughts regarding this matter.

Dave
"A Helicopter Hovers Above The Ground, Kind Of Like A Brick Doesn't"
"If you think you are under pressure - Try opening a sippy cup on an airoplane - 30,000ft in the air"
Greetings From Down Under
Dave Drain
Akela Noble Technologies Pty. Ltd.
Re: Not returning to zero
« Reply #4 on: January 15, 2007, 09:49:15 AM »
Set your servo time to .00087 and you should be good :)

I have been running tests and it is working well for position. you need to have the latest software on everything.
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Offline rcrabb

*
  •  146 146
    • View Profile
Re: Not returning to zero
« Reply #5 on: January 15, 2007, 09:58:50 AM »
How do we know when a new firmware comes out?
Ryan
Re: Not returning to zero
« Reply #6 on: January 15, 2007, 10:24:01 AM »
Dave and/or I will be sure to post that it is out here :)
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Offline rcrabb

*
  •  146 146
    • View Profile
Re: Not returning to zero
« Reply #7 on: January 15, 2007, 01:47:54 PM »
Brian,
What does that servo time setting actualy do? I just want to know what these settings do so I can understand what affects what.
Ryan

Offline kookaburra

*
  •  56 56
  • Fussy? Yep! That's Me ;)
    • View Profile
    • Akela Website
Re: Not returning to zero
« Reply #8 on: January 15, 2007, 02:50:03 PM »
Guy's and Gal's,

I will start a locked thread that I will keep updated with the links to the latest Mach3, NC Pod Mach3 Driver and NC Pod Firmware Updates.

Dave
"A Helicopter Hovers Above The Ground, Kind Of Like A Brick Doesn't"
"If you think you are under pressure - Try opening a sippy cup on an airoplane - 30,000ft in the air"
Greetings From Down Under
Dave Drain
Akela Noble Technologies Pty. Ltd.

Offline Greolt

*
  •  956 956
    • View Profile
Re: Not returning to zero
« Reply #9 on: January 16, 2007, 03:29:29 AM »
Set your servo time to .00087 and you should be good :)

I have been running tests and it is working well for position. you need to have the latest software on everything.

I tried to set servo time to .00087 but it would not stay and reverted to last setting.

So I downloaded latest Plugin and it had a selection in the drop down of .00084 so tried that. Still not returning to zero.

Then I did a clean install of the latest Mach version R2.0.036 set up motors and estop again.

Now the gcode window and line count jump and it stalls around line 980 of the roadrunner.

Tried updating the plugin just in case it changed. Still the same.

Have the latest firmware. Mach version and plugin. Legacy mode turned off for USB

I think to save my frustration I will set this aside for now and watch for updates to come out.