Hello Guest it is May 23, 2019, 07:40:34 PM

Author Topic: External e-stop  (Read 4402 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,815 25,815
  • Carnoustie, Scotland
    • View Profile
Re: External e-stop
« Reply #10 on: June 28, 2012, 06:23:31 PM »
It seems to be working fine here with your xml and code.
How are you doing the RFH?
I click in the GCOde window and scroll to the line I wish to use then press RFH. Alternatively I will scroll with the slider then click on the appropriate line and press RFH.
Hood
Re: External e-stop
« Reply #11 on: June 29, 2012, 01:04:16 PM »
Further to my problems, when external e-stop has interupted my job, i then try to run from line so as not to start again and mach3 scrolls through my g-code problem and stops randomly at a line no where near where the run from line  should return to !!!!!!!!!!!!!!!!!!!!

When you estop during a job, depending on your feedrate, Mach will lose position.  Estop is not a controlled stop.  Here are some suggestions for your estop issue...

(1) First and foremost, make sure you are properly grounded.  The gantry, Z lifter, table frame and controller should all be grounded to a star ground and that should be grounded to a ground rod driven into wet earth.

(2) If the problem still exists, disconnect all estop switches and jump the estop terminals on your BOB.  Does the problem still exist?  If Yes, the problem is not in your wiring or switches.

(3) Remove your DB25 serial cable going from the BOB to the PC and solder a wire to the metal shield part of the end of the cable.  ground that to the star ground on your machine.  That will dissipate any noise being caught by the serial cable.  The cable should only be grounded on one end....The PC end.  You can also ground the metal chassis of the PC to the star ground.

Just out of curiosity, which BOB are you using?
Re: External e-stop
« Reply #12 on: June 29, 2012, 01:45:07 PM »
Thanks for your replies, firstly Hood, how you describe you are doing rfh is exactly what i am doing, scroll down untill i hit the line number that the machine e-stopped at and then click run from line, 80% of the time mach scrolls to this line but other times it goes randomly to a different line and then asks for cycle start, if i press cycle start and ok for the spindle the machine just starts to move with no spindle start, total confusion. As with most issues i am convinced this is electrical noise as the problem is so random with no pattern at all, i think a lot of work has just come my way and start working on re-grounding all the moving parts back to one common point, would you suggest capacitors on limit switch inputs as in previous reply, rrc1962, thanks for reply, i will set to work re-grounding, not sure which bob i will post up when back at work on monday.
regards and many thanks
gary
« Last Edit: June 29, 2012, 01:47:43 PM by gaz221269 »

Offline Hood

*
  •  25,815 25,815
  • Carnoustie, Scotland
    • View Profile
Re: External e-stop
« Reply #13 on: June 29, 2012, 02:26:02 PM »
Is there a message in the ticker line when it E-Stops?
Hood
Re: External e-stop
« Reply #14 on: June 29, 2012, 05:27:21 PM »
I've never found caps to help all that much with excessive noise.  It can't hurt to try.  You would put the cap across the two terminals that your estop loop connect to on the BOB.  That will filter out a little bit of noise on your estop wiring circuit, but that's probably not where the problem is.  If your BOB is grounded and your PC is grounded, then you could have a ground loop going on.  Ideally, the BOB should not be grounded to the machine chassis.  It should be grounded through the parallel cable at the PC end.  We've even had to replace PC's before.  For some reason, some are more susceptible to noise than others.  We've also found some BOB's to be more resistant to noise than others....which is why I asked which one you had.

If your BOB supports estop hardware disable, you can just set the estop port in Mach to 3 or any non-existent port.  When you hit an external estop, the machine will still stop by disabling the drives, but Mach will keep running.  Don't do this unless your BOB supports hardware disable.

We deal with high frequency plasma every day.  The only real fix for excessive noise is proper grounding.