Hello Guest it is July 17, 2019, 11:17:46 PM

Author Topic: spindle speed actual DRO Readout not showing true speed  (Read 5334 times)

0 Members and 1 Guest are viewing this topic.

spindle speed actual DRO Readout not showing true speed
« on: June 09, 2012, 05:34:05 PM »
Hi,
My Name is Mark Lewis and I am new to the forum.Just a brief introduction I have a colchester truimph 2000 under Mach 3 control and I am having a problem with the actual spindle speed DRO that is not displaying the true speed in the DRO.The strange thing is that when opening turn diagnostics the realtime RPM is displaying correctly and if I vary the RPM the speed changes accordingly so I would think that would rule out a hardware issue.I have even tried to disable the turn diagnostics plugin and the result is the same.The version of Mach 3 I am running is 3.043.020 which is not quite up to date with the latest lockdown version.I have also tried various options in the spindle setup but this makes no difference. Has anyone had a similar problem?

Offline BR549

*
  •  6,874 6,874
    • View Profile
Re: spindle speed actual DRO Readout not showing true speed
« Reply #1 on: June 09, 2012, 05:36:49 PM »
Do you have the pulley selection set up correct?

The raw data the diagnostic would see assumes 1 pulse per rev and obviously gives the correct RPM.

Just a thought, (;-) TP

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: spindle speed actual DRO Readout not showing true speed
« Reply #2 on: June 09, 2012, 05:37:24 PM »
When you say "actual spindle speed DRO that is not displaying the true speed in the DRO" are you meaning there is a value and it is wrong or there is no value there?
Hood
Re: spindle speed actual DRO Readout not showing true speed
« Reply #3 on: June 09, 2012, 05:46:56 PM »
Hi,
No the readout remains at zero and every now and then displays 1rpm in the true spindle speed DRO. 

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: spindle speed actual DRO Readout not showing true speed
« Reply #4 on: June 09, 2012, 05:55:53 PM »
Ok if you attach your xml that will be the quickest way for me to check your config is correct.
Hood
Re: spindle speed actual DRO Readout not showing true speed
« Reply #5 on: June 09, 2012, 06:26:19 PM »
Hi,
Sorry about the delay I had to start the controller PC to get the files.I have renamed the mach3 turn xml file to a different name.This was the xml file in the mach 3 directory so I hope it is the correct file.I am running the kernel speed at a higher speed than normal but I did try reduce that and it did not make a difference.
Thanks for the help so far 

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: spindle speed actual DRO Readout not showing true speed
« Reply #6 on: June 09, 2012, 06:32:39 PM »
You have a 470 to 1 ratio for pulley 1, dont think that can be right?
Hood
Re: spindle speed actual DRO Readout not showing true speed
« Reply #7 on: June 09, 2012, 06:46:19 PM »
Hi,
I was not aware that this would affect the speed readout.I will change this and see what the result is.I am still using the machine gearbox so when I was calibrating the spindle analog out I set this to the speed that was on the actual gear speed of the lathe.I will change this and check the result.
Thanks for the help 

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: spindle speed actual DRO Readout not showing true speed
« Reply #8 on: June 09, 2012, 06:50:00 PM »
It all depends on where you have the index pulse sender connected to, for example if you have it direct to the spindle then the ratio would be 1 no matter which gear you are in.
Hood
Re: spindle speed actual DRO Readout not showing true speed
« Reply #9 on: June 09, 2012, 06:57:03 PM »
Then definitely I am running a ratio of 1 as I have a 24v inductive proximity switch on the spindle with a single dog mounted on the hollow pipe at the back.
Thanks again