Hello Guest it is September 27, 2023, 01:04:38 AM

Author Topic: X changed during program run!  (Read 2232 times)

0 Members and 1 Guest are viewing this topic.

X changed during program run!
« on: June 12, 2012, 07:48:39 AM »
Ok, I'm all new to this and have been trying out our China CNC-router for some weeks now,  test cutting different materials using a Dremel as a temporary spindel. So far so good...

I run a little bit more advanced job last week and during the run something happened that seemed to reset one or more axis (either by work offset or other, not sure the different coordinate systems confuse me) and the mill just went straight into a mounting clamp and snapped my poor old (15 yrs) Dremels shaft.

Today I run another quite long job and it happened again, this time I managed to stop the feed before something broke though. the offset this time was on x only and about 5 mm. I managed to re-calibrate by stepping and finish the job, but obviously I don't trust the machine right now...

Funny thing is that when the Dremel broke, I just stopped filming the job with my phone, directly afterwards the mill crashed... Today I picked up the phone and considered documenting the run, perhaps while unlocking it I noticed that the sound changed and that something was wrong and I immediately hit stop.

So, am I confusing correlation with causation here or is there something to it? If not, what is going on?

The router is a machine like this one; http://www.ebay.com/itm/3-Axis-CNC-3025-30cm-25cm-Diy-Router-Engraver-Drilling-Milling-Machine-Driv-/280820666510?pt=UK_Sound_Vision_Other&hash=item416237508e#ht_1001wt_1163 with the included driver board TB6560 (HY-TB3DV-M)

Thanks a lot in advance! -Mike

Offline Hood

  •  25,835 25,835
  • Carnoustie, Scotland
    • View Profile
Re: X changed during program run!
« Reply #1 on: June 12, 2012, 10:11:05 AM »
Attach your xml and some code that it happens with.
Re: X changed during program run!
« Reply #2 on: June 15, 2012, 06:30:49 AM »
Yesterday it happened again. When jogging around at full speed I noticed the steppers to stall or whatever it might be called. The movement stopped and the sound changed. then it picked up speed again, but the result was an axis out of sync. I checked my motor settings and noticed I had them at a max speed of 2000 mm since I was testing speeds, when lowering it to 900 and manually jogging I did not get the "skips"
will run some more and see how it behaves.