Hello Guest it is September 17, 2019, 08:16:09 PM

Author Topic: z axis loosing steeps  (Read 3197 times)

0 Members and 1 Guest are viewing this topic.

Offline dude1

*
  •  1,253 1,253
    • View Profile
z axis loosing steeps
« on: May 17, 2012, 11:53:45 PM »
question what do people think would course z axis to loss steeps, I can do about 500 z move and it will loss about .5mm up not down its a chines machine that has been a problem from the start :(

Offline Tweakie.CNC

*
  • *
  •  7,905 7,905
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: z axis loosing steeps
« Reply #1 on: May 18, 2012, 01:13:01 AM »
Hi Dan,

This problem is probably caused by something mechanical.

Not enough output torque from the stepper motor.

Binding or tightness in the z axis (generally the lead screw and nut) or alignment of the motor / screw through the coupling.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: z axis loosing steeps
« Reply #2 on: May 18, 2012, 07:20:41 PM »
the z axis is belt drive from steeper motor to ball screw its on linear rails, the steeper motor is a nema 36 frame size, 2 of 4 of the bolts holding the ball screw nut are stuffed, the settings are 80 steeps, velocity of 499, acceleration of 371

Offline Tweakie.CNC

*
  • *
  •  7,905 7,905
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: z axis loosing steeps
« Reply #3 on: May 19, 2012, 01:59:13 AM »
Hi Dan,

Try reducing you acceleration for the z axis to 200 and see if this makes any difference (don't forget to save axis setting after making the change).

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: z axis loosing steeps
« Reply #4 on: May 20, 2012, 12:19:24 AM »
had to change z axis settings to 80 steeps, velocity of 300, acceleration of 15 also increased power supply from 54 vdc to 70 vdc it seams to be ok now

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: z axis loosing steeps
« Reply #5 on: May 29, 2012, 11:33:48 PM »
now have new problem the z axis is losing steps going down now.
have check 70vdc power supply no problem there.
checked all pulleys and belts no problem.
checked stepper drivers no problem used different axis driver.
next test will check weight against what motor can handle. will use scales to lift z axis, pull to it moves, then do the maths however that is done.
the stepper motor is a 86bygh450b-06d-15j
voltage is 3 VDC, current 5 A,4 phase, 1.8 step angle, 42 Kg.Cm of forces, how do you work out force to weight i am no good at math.
any suggestion will be tried if can.
will work out weight of z axis when i found scales.
might try a counter weight next to see if that helps.