Hello Guest it is December 12, 2019, 02:09:22 PM

Author Topic: Copycat frustrations. Some advise needed please.  (Read 26598 times)

0 Members and 1 Guest are viewing this topic.

Copycat frustrations. Some advise needed please.
« on: June 15, 2014, 02:03:55 AM »
Like the title states, I'm struggling to get Copycat to work correctly.

First off I had an issue with my video pluggin that I intended to use with CC. Thanks to Klaus that is all sorted now.
I then downloaded the CC manual from the "Members docs" section on the forum. I read through the manual and played around in the default program and was sure that I would be able to use CC for what I needed, so I purchased an Addons licence.
I then found out that I still had the old version of CC installed, so I did a search and downloaded V1.1 and have that up and running with lic.

Now the problem is that I can't seem to get CC to function correctly.
I can set all the Feeds, Safe Z and Holes specs in their respective places. I can jog around using my camera and generate code that will cut a profile shape etc.
My problem arrises when I jog to the centre of a hole I want to cut.

The program requires a rapid or feed move to the center of the hole, that's ok. Then I tell it to "Cut Hole" and I get a popup window stating that the "Tool diameter must be larger than zero".
I have the tool diameter of 2.5 entered in the screen box, but when I type 2.5 in the popup window it rejects it. After much frustration and trial and error, I have found that it will only let me enter a figure between .1 and 2, nothing higher. This is regardless of how big I make the tool diameter in the onscreen box.
If I let it accept a figure of say 1, it posts up code for the hole cut operation, but I get this HUGE circle appear in the toolpath screen and it doesn't match the position or size of the required hole.

I have tried letting the machine cut the complete code. The profile with rapids and feed commands works perfectly, then it tries to cut the huge circle.

I have tried finding out why it does this but have drawn a blank. At first I thought it was a mm to inch thing, but my native units are in mm's and CC doesn't have anywhere to change that. I have created various tools in Mach3, but that doesn't seem to alter anything.

The other frustrating thing is that it overwrites the file and I have now lost the original file that I made.
Is there a way of adding to an existing CC file that has been created earlier? This would help so I don't have to go back and generate the profile section of my code.

I'm at my wits end with CC. Can anybody help me out????

Offline RICH

*
  • *
  •  7,377 7,377
    • View Profile
Re: Copycat frustrations. Some advise needed please.
« Reply #1 on: June 16, 2014, 12:12:15 AM »
oxymax,

Don't know what to say as I wrote the manual by hacking at the program ( there was no documentation on it ) and everything I wrote in the manual worked.
I haven't used it in a long long time. Not manny folks have posted about using it.

You may want to post what version of Mach Mill you are using.
For work i did I always edited and then saved the file in Notepad.

Maybe someone else can will chime in.

RICH
 
Re: Copycat frustrations. Some advise needed please.
« Reply #2 on: June 16, 2014, 01:34:30 AM »
Thanks Rich.
I agree that there isn't much talk about using this part of the program on the forum, which is a shame because it's a nice simple concept.
The version I'm currently using is R3.043.022. I was thinking that maybe I should update, but when I read the section about updating, it recommends, "Some updates may require a reconfiguration of system settings in MACH software. Please do not update MACH software if your machine is running correctly and there are no improvements you require in the current version release".
My machine is running perfectly and there is no mention of any update of CC, so I didn't do it.
I have figured out that I need to save the Notepad file or I will loose the data next time I start a new teach file.
Re: Copycat frustrations. Some advise needed please.
« Reply #3 on: February 15, 2015, 06:20:22 PM »
This post is just an update for anyone else that is experiencing the same issues.
Refer to this topic for what was needed to solve my problem.
http://www.machsupport.com/forum/index.php/topic,29082.0.html

Once again a big thank you to RICH and Mach support.