Hello Guest it is April 11, 2021, 06:41:23 PM

Author Topic: Queue depth going to zero -- causes start/stop motion  (Read 8750 times)

0 Members and 1 Guest are viewing this topic.

Re: Queue depth going to zero -- causes start/stop motion
« Reply #10 on: May 04, 2012, 08:09:08 PM »
That's a good idea (turning off the toolpath display). On the "Configure Toolpath Dialog" I've unchecked all the boxes. That didn't do it (it's still updating the toolpath on the Program Run screen). Is there something I'm missing? I looked through the manuals and could not find how to totally disable the toolpath display during runs. How do I keep it from updating during runs? (Forgive me, I admit I'm new to Mach3).

Likewise, is there a way to turn off the updating of the GCode display? That would probably help too.

The examples I'm running are about 700 lines of g-code. (A real run would be much longer).

Your help is much appreciated.

Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
Re: Queue depth going to zero -- causes start/stop motion
« Reply #11 on: May 04, 2012, 09:07:18 PM »
There's an on/off button on the diagnostics or settings page, lower left. It probably won't help unless you're running several hundred thousand lines of code.
You can't turn of the g-code display.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Queue depth going to zero -- causes start/stop motion
« Reply #12 on: May 04, 2012, 10:02:19 PM »
mach likes a video card, does that mb have video onboard ?
Re: Queue depth going to zero -- causes start/stop motion
« Reply #13 on: May 05, 2012, 08:25:18 AM »
Thanks for the reply. I'm out of town today and will try the on/off button for the toolpath display tomorrow.

I don't have a video card -- it's an on-chip video (i.e. on the Intel G620).
Re: Queue depth going to zero -- causes start/stop motion
« Reply #14 on: May 05, 2012, 05:02:00 PM »
tiger direct, 50 us

Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
Re: Queue depth going to zero -- causes start/stop motion
« Reply #16 on: May 05, 2012, 05:50:51 PM »
I'd guess that not having a video card is not likely to be the culprit with a processor that fast. All you have to do to tell is check the CPU usage with Mach3 running.

6 or 7 years ago, you needed a video card to handle mach3's toolpath display, which is a real resource hog. It hasn't really been an issue with Pentium 4's and up.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: Queue depth going to zero -- causes start/stop motion
« Reply #17 on: May 05, 2012, 10:01:45 PM »
NOW I have seen dual core CPUs not work as well as a single core cpus. Sometimes the PC is NOT loaded with the right driver for windows to run the dual core properly.  SOme manf just loaded copies of the OS directly to harddrives with teh wrong CPU driver loaded . A dual core will run with the single core driver but is VERY lazy.  Make sure your version of windows is running support for multicore CPUs.

COuld be a  mach3 problem running under inverse time mode ???

(;-) TP

Re: Queue depth going to zero -- causes start/stop motion
« Reply #18 on: May 06, 2012, 11:44:36 AM »
Thank you all for the helpful suggestions. Here's more information:

Turning off the toolpath display made little or no difference. (Too bad -- I was hoping that would solve it).

The Task Manager shows the activity in both CPUs. While Mach3 is running, the graphs show small spikes in both CPUs down in the single digits. System Idle is 99% on the average (no other background processes are eating CPU time). Mach3.exe is the only additional process that shows up when Mach3 is launched, and it shows 7 threads running. Total memory used by Mach3.exe is only about 63M. There is plenty of available memory.

I think this shows that it's not a CPU problem or the need for an external graphics card.

What is it in Mach3 that schedules and calls the LookAhead calculations? It's not calling for the lookahead calculations fast enough even though there is plenty of CPU time available. Even on a simple program, when I start running it you can watch the queue depth counter counting up by about 5 per second. It doesn't matter how large I make the LookAhead, the queue depth never gets too high on any program I run. It doesn't matter if the g-code uses g93 or g94.

Any more suggestions?

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: Queue depth going to zero -- causes start/stop motion
« Reply #19 on: May 06, 2012, 12:41:54 PM »
OK I had to go back to some old notes. The lookahead is basically controlling the CV not the Que. The buffer is actually very small in size . I do not know the mechanism behind it you would need to talk to art or brian.

I have watched several programs run here and the que and buffere are running up and down to 0 but the machine is not stopping it remains fluid in motion.

I do know that programs with micro segmented code causes  pauses in motion on some machines.  MACH3 has never been great on 2 or 3d code with micro segmented code because of this problem. IF you increase the length of the segments then the problem normally goes away as it gives mach3 MORE TIME to do its thing . Probably some internal setting to control buffering speeds and preplanner speeds and the coordination between the two.

Mach3 was created long ago when CPU resources were skimpy compared to today.

Just a thought, (;-) TP