Hello Guest it is July 14, 2020, 06:26:07 PM

Author Topic: Pause Mach3 with miss fire?  (Read 10074 times)

0 Members and 1 Guest are viewing this topic.

Offline BR549

*
  •  6,932 6,932
    • View Profile
Re: Pause Mach3 with miss fire?
« Reply #10 on: April 25, 2012, 09:46:00 PM »
oops, (;-) TP
« Last Edit: April 25, 2012, 09:47:44 PM by BR549 »

Offline BR549

*
  •  6,932 6,932
    • View Profile
Re: Pause Mach3 with miss fire?
« Reply #11 on: April 25, 2012, 09:46:49 PM »

OK this should work BUT it depends on IF there is a plugin trying to override it. That is WHY i asked about what THC you were using. IF yours is a simple M3 macro then add the info after the DoSpinCW() statement.

DoSpinCW()
While Ismoving()
Wend
If Isactive(1)=true Then End
If Isactive(1)=false Then
DoSpinStop()
While Ismoving()
Wend
DoButton(1)
While Ismoving()
Wend
Message" Feedhold due to Misfire, Press stop then correct misfire"
End  If
End

(;-) TP
   

Re: Pause Mach3 with miss fire?
« Reply #12 on: April 26, 2012, 06:34:08 AM »
Thnx Terry, works!!...BUT...

There is 2 things:
1. It works when the THC is of, it pause and gives the message. I've tested it on my notebook, so it should stop, since I don't have the "arc Good" signal to work with. But now it continues when the THC IS active - EVEN though there is no signal.. ?? Should the macro set a certain variable back to zero again after you have pressed stop or something?
2. The message stays on the screen, can I get rid of it when pressing START again? How?

Thnx so far!

CD

Offline BR549

*
  •  6,932 6,932
    • View Profile
Re: Pause Mach3 with miss fire?
« Reply #13 on: April 26, 2012, 02:40:42 PM »
That is becasue there is a piece of code somewhere telling it to . It is overriding the M3 code.  WHAT thc are you using. That can answer a lot of questions.

What is in your M3 macro code wise?

(;-) TP
Re: Pause Mach3 with miss fire?
« Reply #14 on: April 29, 2012, 10:22:31 AM »
Why do you disable the THC on small holes?  We burn holes as small as 1/8" with the THC enabled with no problem.

Offline BR549

*
  •  6,932 6,932
    • View Profile
Re: Pause Mach3 with miss fire?
« Reply #15 on: April 29, 2012, 11:33:41 AM »
With air plasma some machines struggle cut wise with small radius cuts such as cirlces. EVEN the advise for Hypretherm is to SLOWDOWN the feedrate to improve cut quality of the small holes or arcs.

With most THC you cannot reprogram the Arc voltage on the fly so when you slow the feedrate down it effects the cutting as the cut parmaters are no longer correct. The easy fix is to turn OFF the THC when you slow down to stop the head from diving into the material.

AND there are problems even with that approach with MACH3 as when you command a macro to turn OFF the thc there is a small dwell involved and it creates a divot in the material from the axis being stalled from the dwell while the torch is still ON.

I had talked to Brian about it but have not heard back from him about a solution. I had hoped we could get a new Gcode to turn the THC on/of internally wilthout the DWELL from an outside macro.

(;-) TP
Re: Pause Mach3 with miss fire?
« Reply #16 on: April 29, 2012, 12:47:22 PM »
In cases like that, we either turn on anti-dive or in most cases just put the THC in manual mode. In manual mode, you contol the Z with a remote pendant. Mach THC is still active so no arc will pause motion. The difference is that in manual mode, once the torch pierces and moves to cit height, you control the Z. Works great for fine detail where the feedrate slows way down.

Anti-dive works also, but I prefer the added control with manual mode.

Offline BR549

*
  •  6,932 6,932
    • View Profile
Re: Pause Mach3 with miss fire?
« Reply #17 on: April 29, 2012, 02:22:41 PM »
Anitdive does not work in this case as it it based on progammed feedrate verses actual.  IN this case teh Feedrate is correct to commanded so the antidive does not kick in. That leaves it cutting with the WRONG arc voltage for the lower feedrate and the head will compensate by going lower.

MOst do not have a manual override for the THC. ADN in most cases it is not needed for simple corrections to feedrate based on arc angle and span.

It is NOT to correct fine detailed artwork but just to correct things like small holes and an ocassional small tight arc.

On my machine I just layers the areas to be adjusted by tool# and I have MACH3 so that it CAN modify the ARC voltage based on Tool# so it takes care of itself. Most do not have those options and just need a simple fix.

(;-) TP
Re: Pause Mach3 with miss fire?
« Reply #18 on: April 29, 2012, 08:07:52 PM »
Our THC just compares set voltage to tip voltage and if tip voltage exceeds set voltage + 10%, it goes into anti-dive mode and suspends Z motion.  This all happens inside the THC and has nothing to do with Mach or feedrate.  If the speed slows, the lerf gets wider and the tip voltage increases.  If it increases to 10% greater that set voltage, anti-dive goes active and prevents the torch from crashing.  If the tip voltage comes back within range inside of 5 seconds anti-dive turns off and Z motion resumes.  If not, it shuts the torch down.  Aside from the fact that your speed slows without reducing cutting current, which may not produce the best cut, the system does do a good job of preventing a torch crash.

I'm guessing that by saying that his THC is "local" that means he  built it himself.  If that's the case, he should be able to make a few mods to the THC and get it working properly.  The problem is really a THC issue, not a Mach3 issue.   IMO, you shouldn't be turning off THC mode in Mach at all.   If you pierce with THC mode off, you stand a good chance of beginning motion before you have a good arc transfer.

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Pause Mach3 with miss fire?
« Reply #19 on: May 01, 2012, 05:23:04 AM »
Terry - the macro you posted above suffers from some subtle timing issues which is why it's not achieving the desired result. Can I suggest some changes?

First wait a tad for the arc to light - you're not giving the poor bugger a chance.
Then replace your TWO "if"s with an "if then else". Things could change between the two tests - then what?
Now the:

DoSpinStop()
While Ismoving()
Wend
DoButton(1)

If THC is ON then turning the torch OFF will result in continued execution of the gcode. i.e. THC will only wait for arcok IF the torch is ON. HOWEVER the feedhold will be executed before the XY movement has had a chance to start. A feedhold issued when there's no motion is ignored. Hence the behaviour the OP is seeing.

The following mod to your code works here. i.e. it will stop execution if no arcok for both THC ON and OFF

Code: [Select]
activateSignal(OUTPUT1) 'start torch

i = 0
While (Not isActive(26)) And (i < 100) 'wait NO MORE than ~second for arcok - season to taste
  sleep 10
  i = i + 1
Wend

If Not isActive(26) Then 'if no arcok
  doOEMButton(1003) 'we're not moving so a feedhold won't work and stop is better anyway
  deActivateSignal(OUTPUT1) 'turn off the torch AFTER stopping otherwise if THC is on - gcode will resume
  message "Stopped due to misfire" 'issue the message
End  If   

Ian