Hello Guest it is July 08, 2020, 12:07:09 AM

Author Topic: newbie - help needed please  (Read 6349 times)

0 Members and 1 Guest are viewing this topic.

Re: newbie - help needed please
« Reply #20 on: March 04, 2012, 08:06:04 AM »
YES! Just did 3200 steps per rev - dont have the 2000 setting - much much smoother!
How can I increase the speed of rotation independently of the number of steps? I changed "velocity" but it does not look like it is going faster...

Thank you so much for your help, I was really getting annoyed with this!

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: newbie - help needed please
« Reply #21 on: March 04, 2012, 08:35:11 AM »
Velocity in motor tuning will increase the RPM of GO moves and Fast Jogs.
If you command a G1 move it will only go at the commanded feed, for example F100 would be 100 units per min if in feed per min mode (G94)
If jogging then you could be in slow jog, press the tab and see what % slow jog is set to, 100% is full rapid. You can have a slow jog% set and still jog at rapid speed by pressing shift key and holding then using the arrow keys.
Hood
Re: newbie - help needed please
« Reply #22 on: March 04, 2012, 04:24:19 PM »
okay...

now I connected my second stepper to the Y axis... set up everything as for X (which is working)...
but Y does not move at all.
I swapped the drivers - X still works... so both drivers are okay
swapped the connections (Y stepper plugged on X driver, X stepper on Y driver) --> Y works but not X... so the stepper works...

so it looks the issue is upstream from the stepper or the driver...

anything I could do here?

many thanks

Thomas
Re: newbie - help needed please
« Reply #23 on: March 04, 2012, 04:31:23 PM »
"Y not working" solved - the datasheet said step pin for Y was 3 and Dirpin was 16 - it is just the reverse

%%^##' datasheet

thanks for putting up with me so far...

T

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: newbie - help needed please
« Reply #24 on: March 04, 2012, 04:58:44 PM »
Yes also said that earlier on ;) The pdf has them  one way at the start and the other way later on.
Hood
Re: newbie - help needed please
« Reply #25 on: March 04, 2012, 05:11:22 PM »
yes you did - but since both 3-16 and 16-3 were quoted you are only 50% right!

thanks for your help... I am sure I will have more questions soon. I struck gold Friday, my company threw away an auto sampler - which basically is a XY table 60cm by 40 cm.
The steppers work fine - I hope to be able to add a Z axis soon

Thomas

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: newbie - help needed please
« Reply #26 on: March 04, 2012, 05:16:41 PM »
Ha ha nope not really, bit more than 50% as I said the screen printing on the board would suggest that you had it the wrong way round ;)

Hood