Hello Guest it is November 27, 2021, 07:34:35 PM

Author Topic: help with step/direction vfd lathe spindle  (Read 7091 times)

0 Members and 1 Guest are viewing this topic.

Re: help with step/direction vfd lathe spindle
« Reply #10 on: February 23, 2012, 04:05:03 PM »
yep, strange thing is i have 1.54 volts at this setting.
Re: help with step/direction vfd lathe spindle
« Reply #11 on: February 23, 2012, 04:28:50 PM »
so if i set the pulley to 1000 and say s1000 on the mdi, i should get 10v at the bob vfd output right?
is there any parameter that could affect this ?

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: help with step/direction vfd lathe spindle
« Reply #12 on: February 23, 2012, 04:53:09 PM »
Afraid I have never set up a VFD with Mach but I have Step/Dir servos for spindles and the Vel in Motor tuning and Pulley Max have to be the same value or you get funny speeds. Might be totally different with VFD setting though?
Hood
Re: help with step/direction vfd lathe spindle
« Reply #13 on: February 23, 2012, 04:55:33 PM »
how do i figure that out?

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: help with step/direction vfd lathe spindle
« Reply #14 on: February 23, 2012, 04:58:52 PM »
Sorry, dont know, as said I only have experience of servo spindles and its simple for that as I know motor is say 4000rpm motor so thats what I have for Vel and Spin Pulley Max.
Hood
Re: help with step/direction vfd lathe spindle
« Reply #15 on: February 23, 2012, 05:34:37 PM »
how do i find the linearity.dat file so i can delete it? i dont see it in the mach3 folder

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: help with step/direction vfd lathe spindle
« Reply #16 on: February 23, 2012, 05:44:04 PM »
Check in the macro folder of the profile you are using.
Hood
Re: help with step/direction vfd lathe spindle
« Reply #17 on: February 23, 2012, 06:07:08 PM »
well, it looks like that method worked now that i deleted the linear thingy.
i got it working at about 2% of the s speed.
what was the linearity.doc???????????
thanks fellas!
Re: help with step/direction vfd lathe spindle
« Reply #18 on: February 23, 2012, 06:15:05 PM »
LOL i still have 1.56v on the vfd line. it has 13v input on the bob.
somehow the vfd run that at full power and .75 ish at half power.
is there no sense to this?
whatever! it works good enough to make parts................................

Offline Fastest1

*
  •  920 920
  • Houston, TX
    • View Profile
Re: help with step/direction vfd lathe spindle
« Reply #19 on: February 24, 2012, 08:27:34 AM »
First, check your battery on your meter to be sure, dont ask my how I know. Dont you have a pot on the C11? board to adjust the output voltage? When the pulley is set to 1000 and you command an S1000 you should get the maximum voltage output of the speed controller. This could be 10v or anything less than your supply voltage depending on the pot setting. In my case I noticed there was no gain in speed with any voltage above 7v so that is where I set my max. A command of S500 should give half the voltage given with your S1000. Btw though you must have discovered it, look in Start/Search/C drive (or wherever you keep Mach) and look for all .dat files. I deleted all of mine. Anyway glad to hear you are getting closer.

so if i set the pulley to 1000 and say s1000 on the mdi, i should get 10v at the bob vfd output right?
is there any parameter that could affect this ?
« Last Edit: February 24, 2012, 08:31:44 AM by Fastest1 »
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)