Hello Guest it is May 22, 2019, 09:32:56 PM

Author Topic: pulse indexing help needed  (Read 2284 times)

0 Members and 1 Guest are viewing this topic.

pulse indexing help needed
« on: January 24, 2012, 10:19:24 PM »
optical switch works fine to the bob but machturn does not seem to use the info well.
i have an xlm if some one can look it over?
the bob red light shows good accuracy but mach seems to skip some pulses and does nothing but read 260rpm. lol
« Last Edit: January 24, 2012, 10:21:59 PM by turbothis »
Re: pulse indexing help needed
« Reply #1 on: January 24, 2012, 11:21:59 PM »
i cant post the xml due to it sharing the name of an old xml that i posted?
Re: pulse indexing help needed
« Reply #2 on: January 24, 2012, 11:29:42 PM »
maybe?

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: pulse indexing help needed
« Reply #3 on: January 25, 2012, 01:38:20 AM »
The Timing input no longer works since the driver was sorted for threading, Index needs to be used instead and the disc must only be 1 slot.
Hood
Re: pulse indexing help needed
« Reply #4 on: January 25, 2012, 11:58:24 AM »
NICE!
i new it was something like this. thanks

so now....i read up to about 930 rpm and then the faster speeds drop to reading 475 and then back up the line.  its like it starts to read in a ratio instead of direct @ 930 and up.
the numbers seem strong and accurate but the rpm rolls over at 930ish and starts reading again at 475 and up.

my little optical switch is reading a .500" slot in a 3" diameter wheel. maybe i need a wider slot?
top gear of the lathe is 1400. i only use about 400 on average though.
« Last Edit: January 25, 2012, 12:01:35 PM by turbothis »

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: pulse indexing help needed
« Reply #5 on: January 25, 2012, 12:02:12 PM »
Go General Config and set you Index Debounce to Zero and try that.
Hood
Re: pulse indexing help needed
« Reply #6 on: January 25, 2012, 04:04:42 PM »
yep, that did it.
thanks a ton!

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: pulse indexing help needed
« Reply #7 on: January 25, 2012, 04:18:25 PM »
No probs :)
Hood