Hello Guest it is October 20, 2019, 05:43:32 AM

Author Topic: Mach 3 wont start the spindle  (Read 15727 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 wont start the spindle
« on: January 18, 2012, 07:35:34 AM »
Hi
Firstly, I am completely new to CNC.  I have aquired a CNC router that is controlled by mach 3, I have spent a few weeks reading and setting up the machine and have got to the point were I can home the x, y and z axis.  The only thing I cant get to work is the spindle.  Mach 3 starts ( i can even run code) and all the axis work but the spindle does not come on.  I have looked in the diagnistics screen and if I toggle the spindle I get a flashing light that i understand means the soindle should be working. Has anyone got any ideas of the mistake i have obviously made...

Thank you
Ashley

Offline olf20

*
  •  318 318
    • View Profile
Re: Mach 3 wont start the spindle
« Reply #1 on: January 18, 2012, 07:59:32 AM »
Make sure you have the correct correct information in Config - Ports N Pins - Motor Output - Spindle.
The light on the diagnostics screen will light up, but if you do not tell it where to send the signal
you will not have any movement.
Hope this helps!!
olf20 / Bob
Mach3, Atlas Knee Mill, 4th Axis, VcarvePro, ESS, Super PID.
Been Heating with corn since 1998
Re: Mach 3 wont start the spindle
« Reply #2 on: January 18, 2012, 09:02:11 AM »
Thanks for the reply Bob.
Had a look throgh the lit that came with the machine and it tells me to configure the spindle in Motor Outpits tab to:  step pin: 16 dir pin 17  step port 1 and dir port 1, this is all done ok.  Now I am getting a new message "PWM Bumped to Minimum Setting"  - if i change the PWM setting i can get rid of this message but still no spindle responce at all.  When I press the spindle toggle button I do hear the relay click buts thats it.
Any help would be much appriciated.

Offline olf20

*
  •  318 318
    • View Profile
Re: Mach 3 wont start the spindle
« Reply #3 on: January 18, 2012, 11:05:39 AM »
What type of spindle drive do you have??
Brand ?
Type Step / Direction, PWM
Any spec will help!1
Are the signals from Mach3 getting to the
spindle control board?

olf20 / Bob
Mach3, Atlas Knee Mill, 4th Axis, VcarvePro, ESS, Super PID.
Been Heating with corn since 1998
Re: Mach 3 wont start the spindle
« Reply #4 on: January 19, 2012, 05:43:41 AM »
Hi Bob

I have done some investigating last night and the results are as follows:

The spindle is not branded, it is a water cooled (seperate pump so the cooling works) GDZ-80-2.2 dia80*210   220v - 2.2kw 8A     400hz  2400rpm

I checked the pins at the end of the parellel cable and I have a constant 4.9v at pins 1 - 9 - 14 - 16 -17

Settings in Mach3:   Motor outputs are set to:  step pin 16        Dirpin 17
                             Output signals:  enable1:  port 1  pin14   
                                                     enable2: port1   pin1
                                                     output1:  port1   pin16

I have power into the spindle control panel but no power at the output leads to the spindle.
pwm base freq 1
minPWM  0

this was set to 10 and 2 but this trips out the system .

If you need any further info please let me know.

Offline olf20

*
  •  318 318
    • View Profile
Re: Mach 3 wont start the spindle
« Reply #5 on: January 19, 2012, 06:51:42 AM »
Can you post your xml file. Maybe we can see something there.
Also can you run the spindle manually??
That would ensure that everything on that end is working.
olf20 / Bob
Mach3, Atlas Knee Mill, 4th Axis, VcarvePro, ESS, Super PID.
Been Heating with corn since 1998
Re: Mach 3 wont start the spindle
« Reply #6 on: January 19, 2012, 09:49:05 AM »
Hi Bob

Just had a local electrical rewinds co out to see the control box, they say it all seems to be operating fine.  They found a digital counter on the main spindle control board and assumed that this would need to change from 000 to 001 or something to start the spindle - therefore , they came to the conclusion that it was waiting for a input signal to start the spindle.  They checked the spindle and all ok.

Sorry i am very new to CNC - can i ask "what xml file and were do i find it?

Thanks Ashley
Re: Mach 3 wont start the spindle
« Reply #7 on: January 19, 2012, 10:48:17 AM »
Found this file ?

[mod: attachment deleted]
« Last Edit: January 20, 2012, 04:50:47 AM by stirling »

Offline olf20

*
  •  318 318
    • View Profile
Re: Mach 3 wont start the spindle
« Reply #8 on: January 19, 2012, 03:25:41 PM »
From the looks of your xml file you should have pin 16 connected to your
input to your spindle drive.
What other devices are you controlling with your outputs?

Also on page 5-17 (may vary some depending on version of manual)
item 5.5.6.2 defines the steps to setup the spindle PWM outputs.

On the MDI screen if you type in M3 S1000 does anything happen?
olf20 / Bob
 
Mach3, Atlas Knee Mill, 4th Axis, VcarvePro, ESS, Super PID.
Been Heating with corn since 1998

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 wont start the spindle
« Reply #9 on: January 19, 2012, 03:28:05 PM »
Dotty
Have sent you a PM.
Hood