Hello Guest it is December 16, 2019, 04:42:23 AM

Author Topic: Need MPG pin numbers of AUX encoder inputs on Galil DMC-41x3  (Read 2914 times)

0 Members and 1 Guest are viewing this topic.

Need MPG pin numbers of AUX encoder inputs on Galil DMC-41x3
« on: December 30, 2011, 08:20:47 PM »
I have an MPG properly connected to a DMC-4143 through the AUX encoder input of axis (X)A.  When I move the MPG wheel I see the 'Encoder Position' increment/decrement for the X-axis on the Mach Settings (ALT-6) screen.  I do not get any motion on the X-axis though.  I have configured the Galil plug-in for MPG #1 Axis X(A) and checked the 'use aux encoder' box.  I have also enabled the MPG #1 under 'Ports & Pins'.  However, there are also settings for the A & B Port # (I assume its 1) and the Pin numbers.  I don't know what values to use for these Pins and assume that's the reason its not working.  All I could find in the Galil manual was that they are interally mapped to address 81 & 82.  Do I need to create a brain file? Can someone please enlighten me.  Thanks!
Re: Need MPG pin numbers of AUX encoder inputs on Galil DMC-41x3
« Reply #1 on: January 10, 2012, 04:25:45 PM »
I resolved this issue.  For anyone reading this thread in the future: you do *not* need to fill in the port or pin numbers in the MPG 'Ports & Pins' when using a Galil controller, you can just leave them blank.  You also don't need a brain file to make MPG work with a Galil.  It just works if everything is configured properly. My trouble came with the Galil software choosing the wrong part number when it registers the controller.  With the DMC-4143, you have to manually register it using the non Plug-n-Play option and choose the proper part number when you register it.  This is complicated by a non-intuitive hidden function of needing to pressing the CONROLL key on your keyboard when you click on the assign IP address box, otherwise you can't manually enter an IP address (see  the end of Galil Application note #4422 where they document all this).  Anyway, MPG works well with the Galil .. just make sure you have it enabled in the Mach3 MPG section & Galil Plugin + have the current Jog Mode (press the TAB key) set to MPG.