Hello Guest it is May 06, 2021, 06:40:01 PM

Author Topic: Problem with 2 stepper motors on one axis and Home switches  (Read 1805 times)

0 Members and 1 Guest are viewing this topic.

Problem with 2 stepper motors on one axis and Home switches
« on: November 13, 2011, 04:04:11 PM »
Hello everybody,
I'm new here and new to CNC World.
My problem is I have a 3-Axis home build CNC and at the y-axis I use 2 stepper motors
That run on spur gears. at first I had difficult time to get those motors to run the same
Direction but I got that figured out. Now the problem is when I set my home switches
and zero out my axis every time I try to reff all home my y-axis is out of wack   and this is
A series problem as my 1200oz steppers want to tear the machine a part! likely I have the e-stop
Switch next to me to shut it down.

Can someone help me please?
Re: Problem with 2 stepper motors on one axis and Home switches
« Reply #1 on: November 17, 2011, 04:18:29 PM »
Newline,
Did you solve this one yet? From your post, I'm not entirely sure exactly what is happening. Is it your Y axis that is dual drive? Is the second drive slaved in software (mach) or hardware? If it's slaved in mach then you have to make sure that both axes (primary and slave) are set to home in the correct direction in Homing and Limits. If you are referencing both axes (home switches on both drives) then you have to uncheck the config setting "Home slave with primary" (sorry I may have that config value name wrong but it's something like that). With this unchecked you can home both sides of the gantry and thereby square it every time you reference to home (provided you have two switches on the axis - one for each drive).
Hope this helps!
« Last Edit: November 17, 2011, 04:21:02 PM by Plan_B »