Hello Guest it is May 18, 2021, 10:18:39 PM

Author Topic: parallel port inputs work, but outputs dont unless restart computer?  (Read 2426 times)

0 Members and 1 Guest are viewing this topic.

I tried searching for this, but had no luck, and as Im not sure what to search.

I switched computers awhile back, system was all working fine, but computer needed upgrading. Now using a Dell Dimension 3000. Everything works fine now, except it seems that if the computer sits long enough without me using it (not sure how long that is, or if its when it sleeps and wakes or what) I start mach 3 to cut something and i go to jog the motors, and the DROs show movement, but the motors do not move. I can see limit switches being switched on the diagnostic page if I push them, thats what gets me.  Its kinda like Mach sees the inputs on the port, but isn't sending the outputs.

It can all be solved by restarting the computer, but I need to figure out why so I dont have to restart everytime I want to use it.

I have the onboard Parallel port in Epp mode and then a pci double port card (used without any problems in the old pc) (although with the mill, I am only using the onboard port 1 at the moment) The PC has a 3.2 ghz processor in Hyperthreading mode, and 2 gigs of ram running 400mhz dual channel.

Any ideas?

Thanks,
Brian =)

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: parallel port inputs work, but outputs dont unless restart computer?
« Reply #1 on: September 19, 2011, 10:00:09 PM »
DO NOT RUN mach3 in sleep  mode. Turn OFF sleep mode. 

(;-)TP
Re: parallel port inputs work, but outputs dont unless restart computer?
« Reply #2 on: September 20, 2011, 01:30:36 AM »
Thanks for the reply,

It never goes to sleep while Im using it, I have the timer set for a long time, and I like to put it to sleep when I am not using it since it is in a enclosed cabinet for plasma dust, and I figured less heat would be better for the computers life when Im not using it.

Is that not ok, even if it never sleeps when its running?

If its not ok, is hibernate ok, or do I just have the choice of letting it run, or shutting it down?

Brian

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: parallel port inputs work, but outputs dont unless restart computer?
« Reply #3 on: September 20, 2011, 02:10:26 AM »
YOU have the choice of letting it run OR shutting it down. ONCE the MACH3 driver enters sleep or hybernate mode it WILL NOT restart itself.

Install a filtered FAN if you think you are going to have heat problems.

(;-) TP