Hello Guest it is September 26, 2023, 09:15:05 AM

Author Topic: spindel wont turn on under mach  (Read 2340 times)

0 Members and 1 Guest are viewing this topic.

spindel wont turn on under mach
« on: September 14, 2011, 01:55:31 AM »
Here is my problem im sure it is a simple fix.

When i run in the milling screenset my spindel come on fine  and chages speed like i want. I would like to  switch to the lathe screen set from time to time to turn some washers or what not useing the mill. well when i run the  lathe screenset everything works just fine except the spindel wont turn on. I have looked at all the ports and pins they are all setup the same as the milling screen   any ideas on what it  could be any help would be great thank you

Offline Hood

  •  25,835 25,835
  • Carnoustie, Scotland
    • View Profile
Re: spindel wont turn on under mach
« Reply #1 on: September 14, 2011, 03:22:29 AM »
Are you simply just loading the screenset from within Mach or are you using a different profile?
If the former I dont know why it would not work but if the latter then possibly just a setting thats not quite right.
If you want to attach your xml I can have a look and see if I can find an issue.
Re: spindel wont turn on under mach
« Reply #2 on: September 15, 2011, 01:25:15 AM »
Than you  hood for responding
Well all i am doing is just useing the default profile that mach has . the general mill set  or the lathe set.  I have not created any profiles. I just simply close the mill set and then open up the lathe set. I went in and configured the ports and pins just as the mill set is .  I am running a  C6 speed controller board i am not useing a relay  to start the spindle i was wondering if that might be the issue.  When i use the MDI bar and type in m3 s1000  it shows that the spindle would normaly be running. Everything else works fine programs  run all the axis with jog and  run .