Hello Guest it is March 09, 2021, 03:03:01 AM

Author Topic: Soft limits warning  (Read 16760 times)

0 Members and 1 Guest are viewing this topic.

Soft limits warning
« on: September 08, 2011, 10:08:43 PM »
I am using a 3 axis router, and the Z zero is at the top of the Z axis, I have the soft limit set at .4". The tools are offset to the spoilboard, so all the Z moves in the g-code are -.005 or more, rapiding between 1"-2" depending on material. I'm getting a warning before running every program that the Z is out of soft limit and if I want to continue, the programs run fine. How do you keep the soft limit enabled on the Z axis without getting this warning every time?

Offline BR549

*
  •  6,944 6,944
    • View Profile
Re: Soft limits warning
« Reply #1 on: September 08, 2011, 10:18:05 PM »
You have a min and max for the SoftLimit THEN you have a slow down zone. What settings have you got for the slow down zone?

The reason you are getting the alert is that you are in the Z zone.

Just a thought, (;-) TP
Re: Soft limits warning
« Reply #2 on: September 09, 2011, 10:09:29 AM »
The safe max is .4; safe min is -7.5; slow zone is .25 - the machine never leaves that range or goes into the slow zone but I still get the warning.

Offline BR549

*
  •  6,944 6,944
    • View Profile
Re: Soft limits warning
« Reply #3 on: September 09, 2011, 10:13:31 AM »
I think you have your settings reversed.

(;-) TP

Re: Soft limits warning
« Reply #4 on: September 09, 2011, 11:02:54 AM »
I don't think I do, if I reverse them soft limits won't turn on. I have run the machine to the end of all the axis and they work as expected. I've attached a picture of the limits setting screen and also what code looks like. My tools are touched off to my vacuum table and the Z work offset is used to define pod or spoilboard height (.5"-2").

Is it not calculating the work offset in the program? Soft limits stay on when I run the program after the warning, but are they now disregarded? If the program is actually going to move past the softlimits will the soft limits stop it?            

Offline BR549

*
  •  6,944 6,944
    • View Profile
Re: Soft limits warning
« Reply #5 on: September 09, 2011, 12:47:24 PM »
OK i had to go back and play with it it has been a LONG time since I played with it last.

You are correct in your settings. But remember those settings are in Machine Corrds not work coord.  You may want to reset the Zmax to a value below Zero as Zero is normally the machine home position and it will trip the limits before it gets to the softlimit.

If you load up a program that violates the softlimits then MACH will warn you with "SoftLimits WARNING" AND the LED stays on BUT If you continue it will limit out and stop.



(;-) TP



Offline BR549

*
  •  6,944 6,944
    • View Profile
Re: Soft limits warning
« Reply #6 on: September 09, 2011, 12:54:52 PM »
Actually I would set the Zhome to be about .25" off the switch location. Then set Z max .1 that gives you a small buffer so when you send the Zhome it will not trip the limit or hit the softlimit.

Just a thought, (;-) TP

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Soft limits warning
« Reply #7 on: September 09, 2011, 02:00:11 PM »
You should not have a negatiove value for X and Y Min and a positive value for Z Max.
As Terry has said they are machine coords so should not be past the axis extent, ie X and Y min is always Zero and Z Max likewise (on a conventional machine before someone chimes in ;)  )
You can if you wish have the values slightly on the positive side for X and Y and Negative for Z but then you may need to disable SoftLimits before homing (depends on settings) Personally I always have them as machine zero.

Hood
Re: Soft limits warning
« Reply #8 on: September 09, 2011, 02:45:36 PM »
I'm not quite sure what you're suggesting to change. The home switches are all 0 in the machine coords, on the Z that's almost the very top of the ball screw, .65 is the exact end of the Z axis in machine coords. The only time the machine homes to Z0 besides homing is in the very beginning or end of a program, during a tool change, but it goes to Z0 in G53, never going any higher than Z0 in the machine coords.

There is no physical limit switch on any of the axis, at least not yet, I plan on hooking them up eventually this is just home the machine came. The rest of the coords I've entered for soft limits work as well, slowing and finally stopping right up to the hard stop, unless the machine is really lost then it shouldn't have a problem homing with the soft limits on, it works with them on now.

I don't quite understand what you guys are suggesting I change - the home offsets where there is all zeros now or physically moving the switch?...

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Soft limits warning
« Reply #9 on: September 09, 2011, 02:51:20 PM »
You can set a Home Off value equal to the distance the Home switches are away fromaxis extent. That will mean when you home the Z for example will be set to 0.65 letting Mach know the position of true machine zero and that way you can set the Soft Limit as 0 for Z Max. Similar for other axis.

Hood