Hello Guest it is May 27, 2020, 11:56:16 PM

Author Topic: RUN Button LED Blinks  (Read 3738 times)

0 Members and 1 Guest are viewing this topic.

RUN Button LED Blinks
« on: July 16, 2011, 04:07:08 PM »
I've been having an annoying issue with Mach.  Not sure if it's that entirely.  I have a CNC plasma Table with Hypertherm Plasma Cutter.  Running CandCNC electronics.  When I run a G-Code file in Mach when the Torch is turning on and off the RUN Button LED blinks.  The problem is though sometimes it blinkls off and I have to continually hit Run again to continue.  The real annoying part is I have to sit there and babysit it or it will turn off and my part won't get cut.  It only happens when the Plasma cutter turns on and off the torch.  It's random too.  There is nothing in the G-Code that tells it to stop.  Also the Reset light does not come on either. Just very simply the Run Button light turns off and it stops.  Is there a setting somewhere, a tolerence setting, or something to stop this from happening.  I've moved my Computer, Plasma cutter and controller box around and tried to see if that would fix it but no luck with that.  My Plasma cutter is grounded to a seperate grounding rod from the computer and controller box.
Any help would be great. 
Thanks!
Robbie

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: RUN Button LED Blinks
« Reply #1 on: July 16, 2011, 04:47:00 PM »
Can you attach your xml so I can see what your config is. There is a Debounce Interval on General Config page which may help if its noise (which it sounds like) but why you would not get a reset puzzles me so the xml would maybe hold that clue.
Hood

Offline BR549

*
  •  6,926 6,926
    • View Profile
Re: RUN Button LED Blinks
« Reply #2 on: July 16, 2011, 11:06:16 PM »
Are you running the CandCNC screensets? IF so then they use plugins that do not always follow the normal Mach conventions you need to ask TOM over on his forum. It sounds like you are loosing the arc signal and mach stops. Could be you are dwelling too long on starts and loose arc or same with end of line if it dwells too long or cuts back  over an open cut then you can loose arc.

(;-) TP
Re: RUN Button LED Blinks
« Reply #3 on: July 17, 2011, 12:34:03 AM »
That makes since as far as dwelling to long.  I have asked him and he was thinking more along the lines of interference. He never mentioned the dwelling to long issue.  Is that a setting I can change?   Just as a try, I'm posting the xml file for Hood to check out also.  I think it's the correct one. 
Thanks for the help!

Offline Tweakie.CNC

*
  • *
  •  8,263 8,263
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: RUN Button LED Blinks
« Reply #4 on: July 17, 2011, 02:06:28 AM »
I have been looking into this issue recently as I was getting it occurring towards the end of a program run. My conclusion is that it was caused by a bad operation (one that Mach does not approve of) called by a running plugin.
Correcting the code order within the plugin resolved the problem for me (I was changing the Mach mode of motion during an operation rather than after the current operation had ended). Another thing found is that this problem is speed related in so far as it appeared on a 3GB PC but not on a 1.8GB PC both running the same OS and V3.043.022.

Don't know if this helps.

Tweakie.
KEEP SAFE !

Offline Tweakie.CNC

*
  • *
  •  8,263 8,263
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: RUN Button LED Blinks
« Reply #5 on: July 17, 2011, 04:12:52 AM »
Please excuse the brain error - in the above post GB should read GHz.  :-[

Tweakie.
KEEP SAFE !

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: RUN Button LED Blinks
« Reply #6 on: July 17, 2011, 05:07:00 AM »
Xml looks ok I think so likely the issue Terry or Tweakie are talking about.
Hood

Offline BR549

*
  •  6,926 6,926
    • View Profile
Re: RUN Button LED Blinks
« Reply #7 on: July 17, 2011, 10:36:13 AM »
Toms CCC stock Plugins run fine here without error and I tend to stretch testing to a fault. 

The dweel can be set several ways . the normal way is throught your CAM package. You set the amount you need to do a clean pierce BUT not any longer as IF you dwell too long the hole gets large and the plasma will loose the arc and the CCC functions will shut off the arc.

Another dwell that shows up from time to time is the M3 dwell in M3ch itself It is located in the Config/portspins/spindle section all dwells here should be OFF.

Tha issue is the only one that I know of that will shut off the Gcode program but NOT Estop the machine.

Just a thought, (;-) TP