Hello Guest it is September 27, 2022, 01:39:21 AM

Author Topic: Wandering Machine  (Read 2336 times)

0 Members and 1 Guest are viewing this topic.

Offline SMA

  •  68 68
    • View Profile
Wandering Machine
« on: July 10, 2011, 03:55:11 AM »
Hey Guys,

New problem with my new machine.  This one is much worse then a few missing steps

Load Gcode and start to run file.  Things go smoothly and within a few hundred lines of code the motors seem to "unlock" and head off in all sorts of directions and motors make a sort of high pitched whining sound (reminds me of stripped gears).  I have let them go for a few seconds to see what they will do next and they tend to lock back up and start to follow code again.

A few details

1.  Code is still streaming while this happens
2.  I can home machine with now issuses and can jog machine.  While jogging the same issue has happened once.
3.  I can run super short files with no issues.  I attached a file that I can run through with no issues.

The strangest part is that it was working well all day and all of a sudden, with no changes to anything, it started acting up.

Is a PC issue.  Do I need to reinstall mach.  Computer fan does seem to run alot but always has.  It is an older aspire running XP.  I installed Mach on the H drive since C was reserved for linux.  Could this be an issue

Any help is greatly appreciated.  i am getting further and further behind.

« Last Edit: July 10, 2011, 03:59:19 AM by SMA »

Offline Hood

  •  25,835 25,835
  • Carnoustie, Scotland
    • View Profile
Re: Wandering Machine
« Reply #1 on: July 10, 2011, 05:58:36 AM »
By the sounds of it your motors are stalling and possibly the reason it looks like axis are going off is because one is stalling and the other continues so  the tool doesnt go where its meant to.
Have you tried lower the Velocity and Acceleration of the axis to see if that helps?
Have you measured the voltage of the power supply to tthe drives to see if the voltage drops when running multiple axis as opposed to a single?
Have you got the correct current set for your motors?

Offline RICH

  • *
  •  7,428 7,428
    • View Profile
Re: Wandering Machine
« Reply #2 on: July 10, 2011, 06:45:28 AM »
- post your xml file
- What is your operating system and Mach version?
- Post info on your drives, motors, power supply
- post a picture of your machine

You motors are skipping and per your other thread you have tried different velocities and accelerations which didn't help.
There are a lot of reasons which could account for your problem.
Post the requested info.

REF: Other thread relative to this thread,
Do not start another thread and keep this thread going until problem is resolved.


« Last Edit: July 10, 2011, 07:07:53 AM by RICH »
Re: Wandering Machine
« Reply #3 on: July 10, 2011, 11:11:30 AM »
I did a router a few years ago that did that.  A few minutes in, it started acting up.  I was using unshielded cable.  Switching to shielded cable salved the problem.