Hello Guest it is December 14, 2019, 03:44:47 AM

Author Topic: Rotary + CV + G00 = Clunk  (Read 5298 times)

0 Members and 1 Guest are viewing this topic.

Re: Rotary + CV + G00 = Clunk
« Reply #10 on: July 05, 2011, 01:16:48 PM »
Hi Bill - with earlier tests I ran (before I tried Ian's suggestion) I found that leaving "Set Stop CV on Angle >" unchecked I didn't run as smooth as I did with it checked.  Do you have a rotary axis?  My problem only happens when I run with the A Rotary axis involved. 

If I run the exact same toolpaths in x, Y, z instead of x, A, z they run without the clunking problem.  (The clunking isn't coming from A (I triple checked).)

It really seems like Mach goes crazy with the acceleration on those G00 moves when doing rotary work.  Ian's suggestion of the dwell before the G00 move seemed to keep Mach from overaccelerating on the following G00 move.  I've looked all over for an option somewhere that might address this, but I just can't find anything.

Ed
Re: Rotary + CV + G00 = Clunk
« Reply #11 on: July 05, 2011, 01:29:04 PM »
By the way, I should have mentioned that I'm running Version 3.042.020 of Mach.

Ed

Offline docltf

*
  •  353 353
    • View Profile
Re: Rotary + CV + G00 = Clunk
« Reply #12 on: July 05, 2011, 04:17:37 PM »
ED

yes i run a rotary.took a lot of playing around with different settings to get me satisfied.after i was satisfied with my
machine it took some time to get the code manageable for the machine.i found that the code should not be faster than the
slowest axis being used.(  say x=100 y=60 z=80 a=25   ) if i do a code with A involved the fastest speed in the code would
be 23. then when doing the code i would keep the Z at tight clearance and turn all G00 to G01 to make the code
run with no rapids.

good luck!
bill

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Rotary + CV + G00 = Clunk
« Reply #13 on: July 05, 2011, 04:52:57 PM »
I'm not certain but I think this problem is down to a bug in Mach. Personally I don't like the fact that Mach blends a move into a following rapid and I can't see any point to it (but you can force this not to happen by my G4 P0). I suggested this to Brian about a year ago but he didn't share my view. With XY this is possibly more of a pain to laser users but as you seem to be experiencing when A is involved it's a more profound problem. It may be worth you taking this over to the yahoo group - good luck with that.

Ian
« Last Edit: July 05, 2011, 05:12:56 PM by stirling »