Hello Guest it is June 13, 2024, 09:39:06 PM

Author Topic: Taig steppers not running  (Read 2676 times)

0 Members and 1 Guest are viewing this topic.

Taig steppers not running
« on: June 24, 2011, 09:16:30 AM »
After a move and putting my Taig mill back together, I found the steppers didn't move even though the system worked perfectly when I took it apart 6 months ago. Mach 3 shows the movement, the motors give the normal slight "clunk" on starting the controller. Recently I was given a newer machine running Vista Basic and replaced the old XP machine. I bought a parallel port card and new cable, installed the Vista patch and ran drivertest.exe (Excellent, then OK). Same problem. The motors even heat up a bit as before.

I assume the problem is not the new parallel port address, AC00. I put AC00 in Ports & Pins as 0xAC00 instead of the typical 0x378 and so Mach 3 should recognize the port. Right? So, I'm down to power supply or Gecko controller and have no idea what to do next. There are no loose wires. I took the controller and the X axis motor off the Taig and tried them separately with the same lack of movement.

Any suggestions? BTW, I always seem to have a problem downloading Mach. The downloading either stops a few seconds into the downloading or downloads instantly but Windows says the file didn't complete. I finally got version 030.

Offline Hood

  •  25,835 25,835
  • Carnoustie, Scotland
    • View Profile
Re: Taig steppers not running
« Reply #1 on: June 24, 2011, 09:52:00 AM »
If you have a volt meter you could remove the cable from the parallel port and then test directly on the port between your Dir pin and Gnd for each axis in turn. Just jog one way then the next and you should see the voltmeter change between 5v and 0v. You may need to change the active state of any limits and E-Stop so that you can reset Mach with the cable unplugged so that you can do this test.


Offline Tweakie.CNC

  • *
  •  9,208 9,208
  • Super Kitty
    • View Profile
Re: Taig steppers not running
« Reply #2 on: June 24, 2011, 10:01:56 AM »
May be an idea to check the new cable also to make sure that Pin1 goes to Pin1, Pin2 to Pin2 and so on. (Not all cables with 25 way D connectors are wired the same).