Hello Guest it is July 20, 2019, 01:55:10 AM

Author Topic: Toolpath not showing  (Read 5865 times)

0 Members and 1 Guest are viewing this topic.

Toolpath not showing
« on: June 11, 2011, 10:25:05 AM »
I'm running CamBam and exporting to Mach3 2010 Screenset in the .nc format. When I load the Gcode, the toolpath does not show. Loading, as an example, the Roadrunner file, it does show and runs nornally. What am I missing? Thanks, Jeff

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Toolpath not showing
« Reply #1 on: June 11, 2011, 10:27:10 AM »
Attach your code please.
Hood
Re: Toolpath not showing
« Reply #2 on: June 11, 2011, 05:50:10 PM »
I'm sorry to have taken your time. Now it's working. The only thing I did was reboot. Thanks for your interest. Jeff

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Toolpath not showing
« Reply #3 on: June 11, 2011, 06:04:11 PM »
No problem :)
Hood
Re: Toolpath not showing
« Reply #4 on: June 12, 2011, 04:19:29 PM »
Hood,

If you or any others have the time, I'd appreciate your looking at the attached. When I wrote the problem had been solved, it was working for a simple square. It seems as soon as circles are involved, I run into all kinds of problems

I'm trying to test the accuracy of a newly built CNC Router, cutting duplicate parts for measurement and comparison. One is a set of rings with drilled holes. The second is two squares, again with drilled holes. The outer circles were not part of the drawing. I should say, the problem of a simple circle still exists, not showing on the screen, but showing the cutting path.

If I've attached the three files incorrectly, please let me know, and if you don't mind, how to do it correctly. It must be clear, I'm new at this. I appreciate your interest and all comments are welcome.

Thanks,

Jeff

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Toolpath not showing
« Reply #5 on: June 12, 2011, 09:16:33 PM »
Change your IJ mode to incremental. Make sure it says G91.1 on the status bar at the bottom. The default in Mach3 is absolute, but almost all CAM programs use incremental IJ.

And a few notes about the screenset. In the upper right corner of the Mach3 Title bar, click the middle button between minimize and close. This should let you then drag the lower right corner to fit the screen. There are some things that aren't meant to be seen outside the 1024x768 window, like the 300.0000 at the bottom.

Also, in General config, uncheck "Boxed DRO's and Graphics" Actually, uncheck all 4 options under "Screen Control". When you restart Mach3, it should look a little better. It looks like you may have Auto Screen Enlarge on, which you definitely don't want.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Toolpath not showing
« Reply #6 on: June 12, 2011, 09:55:55 PM »
Ger21,

All is well, and I thank you so much for your help. I don't understand much of it, but I'm confident I'll get there. I should say I haven't yet run the program on the router, but on the office PC, everything looks and seems to run flawlessly.

So Ger21 and Hood, again, I thank you for your interest and invaluable help.

Best regards,

Jeff