Hello Guest it is April 16, 2021, 08:28:26 PM

Author Topic: G28.1 not hunting far enough  (Read 2299 times)

0 Members and 1 Guest are viewing this topic.

G28.1 not hunting far enough
« on: July 11, 2011, 02:17:51 PM »
Hello, I am having some issues with my plasma. The machine has a floating torch holder, it references the z axis, moves the switch offset, then moves to my set pierce height.  It works as it should, except if the material warps.  Example, the torch is cutting and references at a higher warped point.  When the torch moves to a part that is lower, it calls the g28.1 and goes to reference the z.  It hunts for the switch and doesnt go far enough down, (like a parameter is stopping it) then goes up adding for the switch offset amount and to the pierce height.  Thus being way above the part.  Is there a way to make it go further? 
Heres a sample file.

N0000 (Filename: 1 circle test.tap)
N0010 (Post processor: MP1000-THC.scpost)
N0020 (Date: 24/06/2011)
N0030 G20 (Units: Inches)
N0040 G53 G90 G40
N0050 F1
N0060 (Part: 1 circle test)
N0070 (Process: Inside Offset, Layer 1, T1: Plasma, 0.03 in kerf)
N0080 M06 T1 F20  (Plasma, 0.03 in kerf)
N0090 G00 Z0.5000
N0100 X0.2160 Y0.5179
N0110 Z0.1500
N0120 G28.1 Z0.12
N0130 G92 Z0.0
N0140 G00 Z0.0520
N0150 G92 Z0.0
N0160 G00 Z0.1500
N0170 M03
N0180 G04 P1
N0190 G01 Z0.1250 F36
N0200 X0.0163 Y0.5304 F20
N0210 G02 I0.4837 J-0.0304 F20.0
N0220 M05
N0230 G00 Z0.5000
N0240 X0.0000 Y0.0000
N0250 M05 M30

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: G28.1 not hunting far enough
« Reply #1 on: July 11, 2011, 06:39:14 PM »
I don't know of any parameter that would stop the G28.1 from going UNTIL it hit the switch and then back off.

Perhaps the G28.1 is stoping at the Midpoint value (Z0.12)  Do you have the homed true without switches option checked by chance?

GenConfig/Mill options

Just a thought, (;-) TP

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: G28.1 not hunting far enough
« Reply #2 on: July 11, 2011, 07:57:52 PM »
Another thought do you have teh Z axis home switch setup in config? Sure it is checked as active?

(;-) TP
Re: G28.1 not hunting far enough
« Reply #3 on: July 12, 2011, 10:51:14 AM »
Thanks for the reply,
I checked the home true without switches, it is not checked

Z home is active

Re: G28.1 not hunting far enough
« Reply #4 on: July 12, 2011, 11:02:47 AM »
im looking in my diagnostics and at random times, the zhome light in the input section turns on and off rapidly,  Maybe I have a bad cable that is shorting somehow?  This is happening when I am not running a program just sitting there.