Hello Guest it is May 10, 2021, 04:19:53 AM

Author Topic: Slow motion and harsh noise  (Read 10156 times)

0 Members and 1 Guest are viewing this topic.

Slow motion and harsh noise
« on: May 23, 2011, 04:35:51 PM »
Hi to all,
I need some help with setting up my mach3 configuration. I read almost every post that I could find on the internet but still can figure it out what's going on. The problem is that when I jog the machine it moves smooth and fast but when I load g code for profiling the motion slows down and motors makes a lot of harsh noise. I tried different motor tuning configuration and also many other settings but no lack at all. Some specifications of my setup:

PC:
Processor: Pentium 4  - 3.2Ghz
Ram memory: 2 Gb DDR2

Cnc
Controller:  Tb6560 board
X axis: Nema 34 step motor, 8 micro steps, 16mm screw, pitch 10 mm
Y axis: Nema 23 step motor, 8 micro steps, 16mm screw, pitch 10 mm
Z axis: Nema 23 step motor, 8 micro steps, 16mm screw, pitch 5 mm

Here is the link to short video where you can see and hear what's going on with the machine when jog and when start working on the profile cut.
http://www.youtube.com/watch?v=uwzfqMPyA2Y
I also made screen shots of my mach3 configuration.

Thanks
« Last Edit: May 23, 2011, 04:37:56 PM by Marcin81 »

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Slow motion and harsh noise
« Reply #1 on: May 23, 2011, 05:15:28 PM »
Can you attach your xml and also the code you were running in the vid please.
Hood
Re: Slow motion and harsh noise
« Reply #2 on: May 23, 2011, 05:21:56 PM »
Hello Hood,

Thank you very much for replay. Here are the files.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Slow motion and harsh noise
« Reply #3 on: May 23, 2011, 05:40:43 PM »
XML looks fine, can you try a test by using the circular pocket wizard to see how that runs. Also try the Roadrunner and see how that runs.

Hood
Re: Slow motion and harsh noise
« Reply #4 on: May 23, 2011, 05:45:39 PM »
I did that already, and works great. I don't understand this  ???
Re: Slow motion and harsh noise
« Reply #5 on: May 23, 2011, 06:01:31 PM »
I'm sorry, circle pocket works fine, but the Roadrunner is very slow and also a lot of noise. Another thing is that when I run the Roadrunner the router almost doesn't move but the motion on the screen move fast.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Slow motion and harsh noise
« Reply #6 on: May 23, 2011, 06:19:37 PM »
It looks like the small moves are causing your problem. Circle test was to see if it was fine with multi axis moves, looked fine in jogging but was just checking. Roadrunner and your code are made up of loads of small lines so thats why I wondered if roadrunner acted the same as your code.

Try dropping your acceleration by half and see if that helps any, can always increase later if it does.
Hood
Re: Slow motion and harsh noise
« Reply #7 on: May 23, 2011, 06:28:55 PM »
Doesn't help. Makes it even worst when I jog. Makes the motors stalling.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Slow motion and harsh noise
« Reply #8 on: May 23, 2011, 06:35:32 PM »
Try changing the Step to Active low on Ports and Pins, Motor Setup, it may be your drives need it that way.

Also maybe worth trying Sherline mode but for that you would have to drop your Velocity and set kernel to 25KHz.

Does the driver test look ok?
Hood
Re: Slow motion and harsh noise
« Reply #9 on: May 23, 2011, 07:16:42 PM »
I changed the step to active low and the jog become very jerky and slow. I lower the velocity and acceleration but didn't helped much. Sherline mode makes router slower but no improvement on running g-code.
« Last Edit: May 23, 2011, 07:29:04 PM by Marcin81 »