Hello Guest it is December 06, 2019, 02:38:49 AM

Author Topic: z home switch for toolchanger  (Read 6361 times)

0 Members and 1 Guest are viewing this topic.

Re: z home switch for toolchanger
« Reply #20 on: May 19, 2011, 04:23:58 PM »
version r3-042-040   
ya, my switch works like a champ

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: z home switch for toolchanger
« Reply #21 on: May 19, 2011, 04:59:10 PM »
Not sure where your problem is then as it seems to behave here with your xml when I simulate the input, well except the issue I have here with the active state not changing the LED, that however seems to be an issue with my computer here of which I have not found the answer yet.
So when I use your xml I simulated the Z home switch and pressed the Ref All button, the Z DRO started moving and then when I presses the switch it reversed until I released the switch and then it stopped and set home.

Hood
Re: z home switch for toolchanger
« Reply #22 on: May 20, 2011, 12:56:15 PM »
well, in the end i guess i will just set this by hand.

how do you update the mach 3? worth it?

thanks

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: z home switch for toolchanger
« Reply #23 on: May 20, 2011, 01:25:26 PM »
Just download the version you want to use and install, it will overwrite the current version. It is often wise to keep a backup of your xml and any custom macros etc that you may have in the unlikely event something goes wrong.

Have a look in the Ref All button and see what the script is, to do that go to operator menu then Edit Button Scripts and then you will see RefAll flashing, click on it and the editor will open.

Hood