Hello Guest it is September 26, 2023, 02:01:27 AM

Author Topic: HELP -- K2CNC stopped responding to Mach3 mid-cut  (Read 1830 times)

0 Members and 1 Guest are viewing this topic.

HELP -- K2CNC stopped responding to Mach3 mid-cut
« on: August 20, 2014, 09:05:32 PM »
I'm a first time poster. Usually I'll find various solutions on these and other forums but my machine basically shut down in the middle of a cut (4th of 8 panel job), and I'm pulling my hair out trying to find the source of the problem. I've had communication errors before, the predominant problem being that the red light next to the Enable button on the controller for no apparent reason. I've tried dealing with the E-Stop in ports and pins, changed the debounce and other solutions, but usually shutting everything down and restarting will make the problem go away. Not this time.

Here's my setup:
Windows 7

In the last couple days I've had some eery things going on -- yesterday the piece went off-register about an inch in the middle of a cut. This migration seemed to only happen once.

Today I've been struggling with the red light (e-stop light?) coming on when I turn on the machine. After pressing Enable about 15 times it finally went away. I got through about 90% of an hour long machine operation when the machine just stopped. When I attempted to use the jog to raise the cutter out of the foam I was cutting, the z axis stepper jerked, and then stopped, and then never moved again. I've tried restarting, restoring settings, and a lot more. Nothing on diagnostics is lit up and the red light on the controller no longer comes on except for when I just turn it on. Just silence.

I'm wondering if anyone has any troubleshooting suggestions to isolate this problem. Not sure if its hardware, software, or wiring. Any suggestions would be hugely appreciated.