Hello Guest it is September 19, 2020, 03:49:12 PM

Author Topic: It's SLOW Going!!!!---can someone explain???  (Read 2550 times)

0 Members and 1 Guest are viewing this topic.

It's SLOW Going!!!!---can someone explain???
« on: May 06, 2011, 06:20:47 PM »
OK...I am new here......and usually work with Big Machines......but my question is related to the Hobby Machine I am playing with.....( TownLabs TL518)

I have a great CAD program for doing complex Surfaces....( Rhino )
I have a great CAM system for doing toolpath generation...( Madcam plugin for RHINO)
Simulation in MADCAM tells me I have a 50 min cycle time for Z level roughing.....( GREAT!)

Code output from Post processor is ok ( lots of X movements {with no other AXIS changes} written as a bunch of small steps....uuugh)

ACTUAL RUN TIME ( even using G00 command lines)........over 8 hrs.......

BOTTOM LINE.....THE THING IS JUST BARELY MOVING!!!!

What is creating this problem???

My Guess.....

the small steps do not allow the ACCEL/DECEL curve of the drives to be over written in the smoothing algorithm....hence even though my feedrate is set to 2000mm/min, actual traverse is more like 100mm/min...

How do I overcome this??

Play with motor tuning?

Any help appreciated!

Sam

Offline ger21

*
  • *
  •  6,286 6,286
    • View Profile
    • The CNC Woodworker
Re: It's SLOW Going!!!!---can someone explain???
« Reply #1 on: May 06, 2011, 06:32:03 PM »
Make sure you're in CV mode (G64).
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: It's SLOW Going!!!!---can someone explain???
« Reply #2 on: May 09, 2011, 09:09:23 AM »
G64 has no effect.

Does anyone have some ideas on how to make this thing hum?......

Please Help!

ShoeSam

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: It's SLOW Going!!!!---can someone explain???
« Reply #3 on: May 09, 2011, 02:02:26 PM »
Quote
Code output from Post processor is ok ( lots of X movements {with no other AXIS changes} written as a bunch of small steps....uuugh)

If your CAM is doing that then I would complain to the CAM vendor, no point in having lots of small X only moves when a single line would do.

Setting a larger lookahead may help but if the code is crap the results will be likewise.
Hood

Offline ger21

*
  • *
  •  6,286 6,286
    • View Profile
    • The CNC Woodworker
Re: It's SLOW Going!!!!---can someone explain???
« Reply #4 on: May 09, 2011, 04:02:33 PM »
What are your accel and velocity settings in motor tuning?

Any chance the FRO is set very low?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: It's SLOW Going!!!!---can someone explain???
« Reply #5 on: May 09, 2011, 04:06:34 PM »
I think it will also depend on how vectors are draw.

In Vcarve, if I do not join vector, gcode output is also made of a series of small line of code with a z move between each each.

This is something you could look at too.


Jeff