Hello Guest it is July 18, 2019, 03:30:58 AM

Author Topic: Limit Switch Trips  (Read 3586 times)

0 Members and 1 Guest are viewing this topic.

Limit Switch Trips
« on: March 14, 2011, 06:06:21 AM »
I am a very raw user of Mach3 having had it set up on a Taig Mill for me and up until now I have just run wizards and G code created elsewhere so whilst  I have used it for awhile I don't know my way round its insides very well hence what may be to others a very obvious question.......

My machine keeps tripping out occassionally when fast traversing, usually but not always, in the X axis. The screen says "limit swtich tripped".  It will do this whether its under control of some G code program or if I am fast traversing it with the shift/arrow keys on the keyboard. There seems to be some random element to it in that it doesn't always do it as if it could be down to something like it all being too hot or too cold. It has been milling most of the last few days.

My question is prompted now because its being a particular pain this morning and won't traverse at all in the X axis at speed tripping the instant it starts to move.

There are no physical limit switches so what is tripping and why. Is it traversing too fast? (how to you alter the traverse speed?). The stepper motor apparently have feedback on them so would it be accelerating to fast for the feedback to keep up or something? It could possibly be an acceleration/speed issue because this morning sulk seems to trip as it starts to fast traverse.  I have checked that its in mid travel of the table so its not physically hitting anything and xyz readouts are all within working range.

Grateful for any suggestions, meanwhile I'll be scouring the manual as, typically, its chosen to misbehave with an urgent job on the table

Thanks in anticipation

Paul Martin

Online Tweakie.CNC

*
  • *
  •  7,845 7,845
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Limit Switch Trips
« Reply #1 on: March 14, 2011, 06:31:22 AM »
Hi Paul,

Welcome to the forum.

My first guess would be electrical noise. Do you have an E-Stop fitted or any other inputs ?

Try increasing the debounce setting to 2000 and see if the machine still misbehaves.

Tweakie.
« Last Edit: March 14, 2011, 06:40:59 AM by Tweakie.CNC »
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Limit Switch Trips
« Reply #2 on: March 14, 2011, 06:43:58 AM »
Hi Tweakie

No there are no other inputs and the emergency stop is a very mechanical big red stop button not likely to be a generator of electrical noise.
Its been suggested to me that it might physically have become a little tight and that i should oil/clean the slideways and screws as well as turning down the jog speed so I'm off to try that now

Paul

Online Tweakie.CNC

*
  • *
  •  7,845 7,845
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Limit Switch Trips
« Reply #3 on: March 14, 2011, 06:53:29 AM »
Paul,

It's not the button that generates the electrical noise - it's the wiring between the button and the input on the controller which can pick up the electrical noise.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Limit Switch Trips
« Reply #4 on: March 14, 2011, 07:07:49 AM »
Tweakie

I am on to a solution now and its not electrical noise as such.
At fast traverse there would appear to be a slight tight spot on the X axis which is causing an error signal on the closed loop controller. Turning the Jog speed down and running the table around a bit has got some oil into to the right places and reduced the trip frequency.

I am currently trying to figure out how to alter the fast traverse speeds [told you I was green at this] to something a bit slower so the stepper motors aren't working as hard. Have opened some configuration windows and am scared to change anything.

Paul
Re: Limit Switch Trips
« Reply #5 on: March 14, 2011, 07:25:11 AM »
Hey Paul,
You can set the max speed in the Motor Tuning dialog under Config tab.

If you have no limits, make sure they are all disabled in Ports and Pins.

If there was noise or anothy anomoly with the EStop, you would get an External EStop requested alarm message.

Mach is open loop so there is no feedback, unless you have a unique setup with scales or encoders.
Re: Limit Switch Trips
« Reply #6 on: March 14, 2011, 07:33:26 AM »
Overloaded,

My set up has encoders and feedback from the stepper motors to the controller.
I will go have a look at the config

cheers

Paul
Re: Limit Switch Trips
« Reply #7 on: March 14, 2011, 08:12:47 AM »
Ah, ok. Not too familiar with the closed loop control options but seem to recall that a following error trips the EStop ... not the Limits.
Hope the speed reduction/lube helps.

FWIW   Art mentions Sherline Mode to help with following errors here:
http://www.machsupport.com/forum/index.php/topic,2773.msg22000.html#msg22000

Online Tweakie.CNC

*
  • *
  •  7,845 7,845
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Limit Switch Trips
« Reply #8 on: March 14, 2011, 09:15:49 AM »
Quote
I am on to a solution now and its not electrical noise as such.
At fast traverse there would appear to be a slight tight spot on the X axis which is causing an error signal on the closed loop controller. Turning the Jog speed down and running the table around a bit has got some oil into to the right places and reduced the trip frequency.

Paul,

It depends on the way your machine has been wired, but from what you have described, I doubt Mach would be able to detect this error has occurred. This being the case, the limit trip would be unrelated to the following error you are observing.
Very curious this one.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Limit Switch Trips
« Reply #9 on: March 14, 2011, 09:18:07 AM »
Feed speeds now adjusted down quite a bit and machine is now milling quite happily.
Hopefully my issues are now solved until find some new ones.

Thanks to for the assistance

Paul