Hello Guest it is May 19, 2019, 11:23:42 PM

Author Topic: Mach3 behaving strangely  (Read 5182 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach3 behaving strangely
« Reply #10 on: March 12, 2011, 10:57:24 AM »
Hi Scott, you have A slaved to X and A set as Angular.
Is this intentional ?
My guess, it's hung up in the homing routine like Hood mentioned as A is never getting referenced.
Home slave with masrer is also checked.
Un-slaved A and it appears to work normally now in sim.
Russ
« Last Edit: March 12, 2011, 11:01:36 AM by Overloaded »

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 behaving strangely
« Reply #11 on: March 12, 2011, 11:02:15 AM »
Sorry had someone come in. Yes I think that is the problem.
Hood
Re: Mach3 behaving strangely
« Reply #12 on: March 12, 2011, 11:18:50 AM »
OK,
Sounds like you guys are on to something here. Please help me set up my machine correctly.

I have A slaved to X because I have 2 motors on my X axis. However, I currently have only 1 home sensor on my X axis. What I will do (I have ordered the parts) when I get the parts is have 2 home sensors on 2 separate inputs so that I can "square" my gantry with a homing routine.

But, currently I have only 1 home sensor for the X. I am confused about slaving, when I first set up my machine I slaved A to X and the machine would jog via the keyboard normally, BUT, when I clicked ref all home only 1 of the X motors would run and the gantry would try to twist until it stalled. I posted a question about this on another CNC forum and was told to check "Home slave with master axis", this seemed to fix my problem because now both motors run when I home. But it has caused this issue.

So what am I to configure to get it to run correctly  with the 1 X axis sensor that I have now?


What am I to configure when I get the second home sensor  and  i want to square my gantry with it?

Thanks guys,

Scott 

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 behaving strangely
« Reply #13 on: March 12, 2011, 11:21:53 AM »
Yes because you have the A home switch enabled, disable it and all should be fine.
Hood
Re: Mach3 behaving strangely
« Reply #14 on: March 12, 2011, 11:26:44 AM »
Uncheck A as Angular
disable the HOME swit for A in Ports and pins/input signals
check Home slave with master
 when you get the second sensor, install and enable it in config
Re: Mach3 behaving strangely
« Reply #15 on: March 12, 2011, 11:46:52 AM »
Wow! Thanks, I am a total newbie and just could not figure this out. That solved my issue and shed light about the way that Mach "thinks". That seems to be the largest problem of learning new software is getting your head wrapped around the logic.

Thanks again to all who shared your time with me.

-Scott
Re: Mach3 behaving strangely
« Reply #16 on: March 12, 2011, 11:48:07 AM »
 :)
The learning is never ending.
Glad we were able to help.
 :)