Hello Guest it is July 17, 2019, 11:18:31 PM

Author Topic: slow stepping on power up  (Read 4270 times)

0 Members and 1 Guest are viewing this topic.

slow stepping on power up
« on: November 13, 2006, 03:03:51 PM »
Hi,
I installed a new PC to run the CNC software, and on a whim, I have the, XP-home software auto load and run the Mach 3 program (ver 2.005). Each time I boot up the computer and clear the RESET, the motors run at an incredibly slow speed. I can hear every step as the motor starts to accelerate. I is running about 1% of normal speed. Everything else seems normal.  To fix, I stop/exit the program and restart from the desktop icon. The hard drive was formatted and loaded with XP-home, serial touch-screen driver, Mach3, AutoCAD, a couple freebie text converter packages, and precious little else (just enough to make it run).

Any ideas?
Thanks.
Bill

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: slow stepping on power up
« Reply #1 on: November 13, 2006, 09:25:47 PM »
Hi, Bill

When you startup the computer with mach3 running the first time view MDI page Bottom right corner, check the Profile: setting, make a note of it then restart Mach3 with your Icon, Check that they are the same, if not your loading 2 different XML files.

If this is the case right click on the icon that is working properly, click on Properties, are the values the same as your autoboot of Mach3. ?

Hope this Helps, Chip
Re: slow stepping on power up
« Reply #2 on: November 14, 2006, 07:18:41 PM »
Run a driver test please
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: slow stepping on power up
« Reply #3 on: November 18, 2006, 05:30:58 PM »
I checked both profiles and both said "Mach3Mill". I expected this because I had coppied the desktop shortcut directly into startup.

I just ran a driver test and it was normal. I don't have anyway to do a driver test before I boot into the Mach3 program, and the driver test issues an error if I have Mach3 open when I try to run it. Once I exit Mach3, everything goes back to normal. It is consistant and does it every time.

I looked into the configuration while it was acting up, and the settings looked correct. I then observed the interrupt timing and that also looked normal. One interesting thing, when I shrank the window to get to the desktop, it shrank down slowly, taking several seconds to get down to the task bar. The buttons and the folder selections are running at full speed, and loading a G-code file seems to all go at normal speed. 

I suspect that something that Mach3 needs is starting after Mach3 is loaded and is bogging it down. I should set up a 30 second timer to delay its starting.

Thanks.
Bill
Re: slow stepping on power up
« Reply #4 on: November 19, 2006, 10:31:47 AM »
To run the driver test open the Mach3 directory and look for Drivertest.exe and run only that. You can't run mach3 and the driver test at the same time.

thanks
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: slow stepping on power up
« Reply #5 on: November 20, 2006, 12:46:43 PM »
Brian,
I ran the driver test several times and it always looks normal. It is mostly a straight line at 40us with a few spikes that don't deviate more than +/- 25us. The test runs for about a minute and indicates that it competed. The program does not seem to offer any other conclusion about the test.
Thanks.
Bill
Re: slow stepping on power up
« Reply #6 on: November 20, 2006, 05:54:01 PM »
Run MSconfig and turn off all the stuff on startyup.. there has to be somthing that is doing it...
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Offline chad

*
  • *
  •  361 361
  • When the going gets weird, the weird turn pro.
    • View Profile
Re: slow stepping on power up
« Reply #7 on: November 20, 2006, 06:18:32 PM »
Just for fun do a quick test for me. Reboot don't load mach right click on your desktop > properties > settings tab > advanced > troubleshoot > and move the slider back two notches. Apply and reboot then load mach and see if it is still doing the same thing.
I ran into this problem with another piece of software lately and this fixed things for me.

I make no guarantees but it is worth a shot.

Chad

 
Re: slow stepping on power up
« Reply #8 on: November 20, 2006, 07:50:24 PM »
Hi,
I ran MSConfig and found 7 processes in the startup. I unchecked all but the Mach3 and rebooted. Mach3 ran normally, so one of other 6 programs was contributing to the problem. I enabled three that were relatively obvious as harmless (msn, wireless LAN, and touch screen serial driver), and all was well. Enabled Autocad, and again all good. Enabled LogMeIn, and again all good.

The bad boy was Skype. I don't know why I installed it in the first place, but now it is disabled, and all seems to be well.

I have not tried backing off on the video accelerator yet, I may try that some day, but that doesn't seem important at the moment.
 
Thanks.
Bill

Offline chad

*
  • *
  •  361 361
  • When the going gets weird, the weird turn pro.
    • View Profile
Re: slow stepping on power up
« Reply #9 on: November 20, 2006, 09:24:07 PM »
If you found it then disregaurd the last post. Glad to hear you got it working.

Chad