Hello Guest it is November 29, 2021, 08:10:18 PM

Author Topic: missing steps  (Read 3652 times)

0 Members and 1 Guest are viewing this topic.

missing steps
« on: October 29, 2013, 03:48:30 AM »
Hi guys, just received licence so now can test extended programs, kool! Have encountered some issues tho... I have experimented with individual axes and find I can run
them pretty damn hard, 1500mm/min at 1000 pulse per mm. Steppers get hot at that speed. Backed off the motor current to bout 3/4 rated and slowed rapids to
600mm/min, ie 10kHz. Because I am using 10:1 reduction have got torque to burn, dont stick your finger in it, will rip it off and look for the arm!

My problems start when I do coordinated moves.

Sounded initally like a bad bearing or tooth off a gear, had me worried. I stripped down and checked yet again. The screws and rails etc are all second hand but all
originally top spec items and no mechanical issues I can detect nor any pattern to the intermittant glitch. Occassionally the glitch would precipitate a stall.

I beleive now my computer is at fault, ie occasionally the pulse train goes offline, 'glitch', and if when pulses return the accel is too steep, stall.

Can anyone suggest likley programs or processes running on my computer that are likely culprits? I dont have antivirus installed, reckon the antivirus stuff buggers up my
computer worse than a virus!
My wife left with my best friend...
     and I miss him!

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: missing steps
« Reply #1 on: October 29, 2013, 04:20:00 AM »
Try increasing the pulse width.
Make sure the active state of the Step Pulse is correct for your drives.
Make sure you are not using a higher kernel in Mach than you actually need.
Try reducing the acceleration and Velocity.

Regarding optimisation here is the info from Mach ftp
ftp://machsupport.com/Extra%20Information/XP%20Optimization%20Guide.txt

Hood
Re: missing steps
« Reply #2 on: October 29, 2013, 06:09:41 AM »
Thanks Hood, working my way tru the list. Daren't run the machine at the moment, the funny noises wake the household. God knows what they think
of the funny noises I make!
My wife left with my best friend...
     and I miss him!
Re: missing steps
« Reply #3 on: October 29, 2013, 10:42:18 AM »
Also check if you are running in exact stop mode (noisy) or CV mode (quiet and smooth).
John Champlain
Re: missing steps
« Reply #4 on: October 29, 2013, 02:15:12 PM »
what other programs are you running on the pc.
Re: missing steps
« Reply #5 on: October 30, 2013, 05:31:58 AM »
Thanks for your replies guys. I have followed the recomendations on the list directed to by Hood. I try to keep my computer reasonably lean, it is old and entry level at that. Need to go thru the services list with a fine tooth comb still but have made great improvement in M3 as is.

Reducing speeds and accels makes things run cooler and sweeter and backed kernel speed bsck to 25k, still way fast enuf for my steppers. The code was running in CV mode when I encountered the problem I descibed.

My computer is general service so has internet, movies and all the usual junk. One program I do use (less than I should!) is Atmel Studio, a programing enviroment (universe actually) for Atmel processors. In order for it to work it requires MS .NET code. Ever since I loaded it I have had more errors and similar. I have a few engineering CAD/CAM type apps as well but none running when M3 active.

With the suggestions enacted so far I have been able to run PCB mill code for 2.5 hrs, no stalls or missed steps even at speeds where steppers overheat.
In fact I have been writing this post at the same time, no probs. Tried running a movie, again no probs. When I tried a simple Gcode veiwer and started
skewing axes I noticed some 'cycle stealing' but not enuf to upset M3. Excellent!!!

I'm not out of the woods yet tho... The PCB code I'm running is essentially aligned with x-y axes. Have noticed a cycle steal each time and axis crosses its zero. With a cut in x direction, y say +20mm and constant for the duration of the move, as x passes from positive to negative there is a slight hesitation. Seems to happen with G1 or G0 moves. Happens on other axis as well. Not enuf to lose steps but why?. The code does not include a x 0.0
or anything?

I have not yet fitted limit switches and have set nachine zero at center of travels. I could set zero at one extreme so cutting code never passes over it but would still like to know why this glitch occurs, often learn more by the unexpected.
My wife left with my best friend...
     and I miss him!
Re: missing steps
« Reply #6 on: October 30, 2013, 05:46:37 AM »
As pc's are so cheap in the second hand market, get another to run the machine. Put windows xp and mach3 on it and nothing else. Recently I came across a problem where a cad/cam program was affecting the z axis, so keep the pc that runs the machine clean of anything other than the operating system and mach.

NO INTERNET, NO VIRUS PROTECTION, NO MOVIES, NO ATMEL STUDIO, NOTHING OTHER THAN MACH3.

Imagine your changing tools and something in the computer tells the z to drop and your hand is under the tool, you get a tool through your hand a bit more serious than a few missed steps.
Re: missing steps
« Reply #7 on: October 30, 2013, 06:24:15 AM »
Thanks, great advice. While experimenting I have had one crash where wire fell out of BOB and so negative moves were treated by driver as yet another
positive... Shore a flex coupler and no more. LUCKY My calculation suggests axis stalls at 70kgf. I think a crash is raher more than that, certainly enuf to
injure.
I bought home today bunch of micro switches for limits and home switches. The home switches are good ones (Honeywell made in bloody China!) with
0.05 mm max differential and 5mm overtravel, roller plunger types. Limit switches rather more prosaic units, not over concerned with accuracy at limits,
its All Stop in any event.

The problem I encountered tonite seems more a M3 thing. It was not my computer not concentrating when axis passes zero but rather M3 doing some
calcs or something.
My wife left with my best friend...
     and I miss him!