Hello Guest it is October 19, 2019, 01:47:59 AM

Author Topic: New with very slow drive problems  (Read 6823 times)

0 Members and 1 Guest are viewing this topic.

Re: New with very slow drive problems
« Reply #10 on: February 17, 2011, 04:30:07 PM »
Changing the pulse settings did not do anything.

There just seems to be some scaling factor wrong for the velocity once it is sent to the drive controller.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: New with very slow drive problems
« Reply #11 on: February 17, 2011, 04:33:47 PM »
If you zero the X DRO and then in MDI command a G0X1 does it move 1 inch?
What type of drives do you have?
On the diagnostics page what does the frequency say and also the Time in Int?
Hood
Re: New with very slow drive problems
« Reply #12 on: February 17, 2011, 04:54:20 PM »
Changing the pulse settings did not do anything.

There just seems to be some scaling factor wrong for the velocity once it is sent to the drive controller.

If it helps any the controller is the Geckodrive G540 and the steppers I am using are the ones listed on this website: http://geckodrive.net/g723-280-p-45.html
Re: New with very slow drive problems
« Reply #13 on: February 17, 2011, 05:02:40 PM »
The drive does move 1 inch on all 3 axis correctly, I will get back to you on the frequency, Time and Int.
Re: New with very slow drive problems
« Reply #14 on: February 17, 2011, 05:22:51 PM »
The time and int is between +19 and +20 when moving and when not jogging it is between +9 and +10.
I am not sure if I was looking at the correct number but the pulse frequency was everywhere between 650 and 800.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: New with very slow drive problems
« Reply #15 on: February 17, 2011, 05:26:11 PM »
I would say that is your problem then, your computer is not pulsing correctly. Drop the kernel down to 25KHz and obviously you will have to drop the velocity to suit and see hwo that goes.

Hood
Re: New with very slow drive problems
« Reply #16 on: February 17, 2011, 05:35:09 PM »
I have tried it at 25KHz and all the other settings up to 100KHz.  The speed is identical at all settings.  I will try again later but right now I have some other work that needs to be accomplished.

Do you suppose that the problem could be related to running Mach 3 off of a laptop?
« Last Edit: February 17, 2011, 05:40:31 PM by mrpizzaman09 »

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: New with very slow drive problems
« Reply #17 on: February 17, 2011, 05:40:14 PM »
You will either need to get another computer or try and clean that one out.
What are the specs of the computer?
Hood
Re: New with very slow drive problems
« Reply #18 on: February 17, 2011, 05:49:27 PM »
It is an IBM thinkpad T43.  I have it on a separate port replicator so I may try plugging directly into the port on the computer.

It has a 1.83 ghz single core processor, 1gb of memory.  The OS is loaded with crap though so I will try doing a fresh install of XP and start over.  It will be a Saturday project.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: New with very slow drive problems
« Reply #19 on: February 17, 2011, 05:58:58 PM »
Laptops are not supported by ArtSoft unless using external pulsing devices and for good reason. That reason is the vast majority  are very difficult to get Mach running right due to the power saving features in them, seems the more modern your laptop is the worse of a problem you are likely to have.
Disable all power saving features especially if you can find any in the BIOS but to be honest you will save yourself a lot of grief by going and buying a cheap second hand desktop and using that.

To give you an idea what you are fighting think about this, the time in int you reported is 20uS, when running at 45KHz the computer interupts at 22.2uS so your computer is using 20uS for pulsing and that is only leaving 2uS for everything else that is going on in Windows and Mach itself, I am amazed you have not had constant crashes.
Hood