Hello Guest it is August 08, 2020, 12:08:34 PM

Author Topic: Slow down at 1600 ppr  (Read 5866 times)

0 Members and 1 Guest are viewing this topic.

Offline faby

*
  •  74 74
    • View Profile
Slow down at 1600 ppr
« on: July 09, 2007, 01:35:01 PM »
I have some problem with high number of pulse
Setting my stepper driver to 1600 ppr and setting mach to 60khz, at 4300 mm/min (about 169 ipm) per axle.
When I manual move 1 axis it's ok, but when move 2 axis  together they showily slow down or lose steps, 3 axis together... Disaster!! ;D
I tried to use 2 axis but only 1 driver connected, well the only one connected slow down anyway

My pc is a pentium 4 3Ghz with 1 Gb of ram.
I installed mach on a clean version of windows as artsoft recommend.

I tried to install the latest version 2.01 and set the kernel from 45 to 100khz but nothing change.

Why it happen

Thanks
Fabiano
FxModel Italy

Offline Chaoticone

*
  • *
  •  5,628 5,628
  • Precision Chaos
    • View Profile
Re: Slow down at 1600 ppr
« Reply #1 on: July 09, 2007, 08:15:20 PM »
Hey Fabiano,
    Is this a new set up or has it been runnig fine at slower speeds before? Is your power supply big enough?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline faby

*
  •  74 74
    • View Profile
Re: Slow down at 1600 ppr
« Reply #2 on: July 10, 2007, 02:58:21 AM »
it is a new set up, because I want to change the steppers with servos so I need to set an higher value of ppr

It's working fine from 2 years and 1.200 hours of 3d works, but usually it is sets to 400 ppr, rapid speed at 315 IPM and working speed at 200 IPM.

I think it is not a hardware problem because, as i told, if I connect only 1 driver to the pc and I manually move 2 axis, the only one that is moving and connected, immediately slow down  :'(

Offline Chaoticone

*
  • *
  •  5,628 5,628
  • Precision Chaos
    • View Profile
Re: Slow down at 1600 ppr
« Reply #3 on: July 10, 2007, 09:43:54 AM »
Hey Fabiano,
    I have a few questions. You keep saying PPR. By this, do you mean steps per revolution or steps per unit? Are you set up in inches or mm as your default unit? I assum mm. Do you still have the steppers hooked up or the servos? What is your gearing for both set ups? What drives do you use for each, microstepping? If so, how much, 10, 8,2? Can you post both XMLs? Have you tried it at 25KHz? If you go to a higher pulse rate in Mach, do you reboot and does it stay at the higher pulse rate after you reboot? Can you run a driver test and take a screen shoot?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline faby

*
  •  74 74
    • View Profile
Re: Slow down at 1600 ppr
« Reply #4 on: July 10, 2007, 10:12:53 AM »
Hi,
With PPR i mean Pulse Per Revolution, I set mm as main unit, I'm still tring with stepper and I set it to 8 microstep without gear reduction

4500mm/min in my case is 900rpm so 15 rates per scond, so 15 rates per second at 1600 pulse per rate = 24khz per axle and so 48khz for 2 axis....

then i can't run mach at 25khz.

Anyway it's not a driver problem because it happen also with only 1 drived hooked

Offline Chaoticone

*
  • *
  •  5,628 5,628
  • Precision Chaos
    • View Profile
Re: Slow down at 1600 ppr
« Reply #5 on: July 10, 2007, 10:28:45 AM »
Hey Fabiano,
     If your fastest axis can run at 25KHz, there is no need to go any higher on the pulse rate. The pulse rate does not increase with the a higher number of axis. 25Khz mode will run 6 axis at 25KHz.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline faby

*
  •  74 74
    • View Profile
Re: Slow down at 1600 ppr
« Reply #6 on: July 10, 2007, 01:28:53 PM »
I'll try at 25khz  :-X

Faby

Offline faby

*
  •  74 74
    • View Profile
Re: Slow down at 1600 ppr
« Reply #7 on: July 11, 2007, 12:26:39 PM »
I tried to set mach at 25khz but it says that the speed is too high for 25khz timing(7000 mm/min at 1600 Pulse Per Revolution)
So I set it to 35khz and it seams to work fine but at 6500 mm/min because 7000mm/min was still to high for 35khz (an allert windows advise me of that)

Now the question is, why at 45khz or more it doesn't work with that settings?
Now I'm sure that is not a stepper driver problem.
As i told i use a pentium 4 at 3ghz and 1gb of ram.

Offline faby

*
  •  74 74
    • View Profile
Re: Slow down at 1600 ppr
« Reply #8 on: July 11, 2007, 12:29:48 PM »
oops I forget...
attecched you can find some screenshots of driver test and the xml file

Faby