Hello Guest it is July 18, 2019, 07:51:29 AM

Author Topic: Metric Vs Imperial  (Read 6618 times)

0 Members and 1 Guest are viewing this topic.

Offline Chaoticone

*
  • *
  •  5,524 5,524
  • Precision Chaos
    • View Profile
Re: Metric Vs Imperial
« Reply #10 on: November 16, 2006, 03:05:28 PM »
Not in the least. You are sharp as a tack Hood. Again, you are my hero. ;D
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Metric Vs Imperial
« Reply #11 on: November 17, 2006, 02:07:18 AM »
Thanks guys!  This was a very helpful suggestion as having separate XML files will be the perfect solution for me.  I have a slight initial problem of setting the motor tuning values for the metric system.
Here is my current settings for the Imperial units.   I think the steps per (which is currently 32000) should be divided by 25.4.  However, I am not sure if should divide velocity (currently 20.25) or acceleration (currently 3.9023438) by 25.4
Thanks,
Jason
« Last Edit: November 17, 2006, 02:23:59 AM by jporter »

Hood

*
Re: Metric Vs Imperial
« Reply #12 on: November 17, 2006, 02:19:56 AM »
I think you would multiply velocity and acceleration by 25.4. eg 20.25inch/min = 514.35mm/min
 You can of course mess around a bit to see what it will run at.
Hood
Re: Metric Vs Imperial
« Reply #13 on: November 17, 2006, 02:25:58 AM »
Thanks Hood.  That did the trick.  I was looking for a formula to keep both XML files in synch with the same tuning settings but in different units.
--Jason

Hood

*
Re: Metric Vs Imperial
« Reply #14 on: November 17, 2006, 02:28:26 AM »
:)
Re: Metric Vs Imperial
« Reply #15 on: November 18, 2006, 12:09:11 AM »
Sorry to drag this thread on but I have one more related question.  How do you set the default feed rate and the default rapid speed?  In the DRO, the default feedrate shows as 6 which is OK for imperial but for the metric system, I would like to set this to 150.  I can set it in the feedrate button in the feedrate setting but seems to revert back to 6 every time I start the program. Also, where do you set the default speed setting for G0 ?
Thanks

Hood

*
Re: Metric Vs Imperial
« Reply #16 on: November 18, 2006, 03:14:07 AM »
For G0 that is set by your motor tuning, whatever your velocity is set to is you rapid (G0)
Not sure where to set or even if you can set the default feedrate but why would you need this anyway?  if you are comanding a move whether by program or MDI all you need to do is put F200 or whatever after you G1 move.

Hood

Offline John S

*
  •  111 111
  • Nottingham England
    • View Profile
Re: Metric Vs Imperial
« Reply #17 on: November 18, 2006, 04:19:56 AM »
Put F250 or whatever you want in the initialisation string on the config.
That then becomes your default feed.

John S.