Hello Guest it is April 19, 2021, 12:42:45 AM

Author Topic: K2 KG3925 settings for Mach3 here  (Read 5892 times)

0 Members and 1 Guest are viewing this topic.

Offline sploo

*
  •  13 13
    • View Profile
K2 KG3925 settings for Mach3 here
« on: November 11, 2006, 05:39:49 PM »
A number of people, myself included, have been looking for setup files for K2’s KG3925 router for Mach3.

Using a file posted by Zealous (many thanks), I’ve been working on a configuration for my 2006 model KG3925, and I’ve posted it here in the hope it may be useful.

All my comments on orientation refer to the image at the bottom of this post.

What’s in this setup

  • The motor tuning has been left unchanged from Zealous’s file – 10160 steps per unit, 200ipm max velocity, 18.3 inches/sec/sec acceleration.
  • The axes have been setup with the 39” as X, the 25” as Y.
  • The origin (X=0, Y=0) is at the front left of the working area – to achieve this, Dir LowActive is not set for the Y Axis on Config->Ports and Pins->Motor Outputs
  • In Config->Homing/Limits the Home Neg settings will move the X axis left, Y axis away and Z axis up when the REF ALL HOME button is pressed. This will move to the locations of the home switches on this machine (as desired).
  • Once referenced, the Home Off. settings will set the axes to X=0, Y=24.25, Z=0. This means that when moved to X=0, Y=0, the Y axis is about 0.25” above the limit of the axis.
  • In Config->Homing/Limits the Soft Max and Min values will cause the machine to slow and stop (when jogging) about 0.25” from the front edge (Y=0) and right edge (X=38.75) of the machine (as well as slowing and stopping just before the ends with the home switches (X=0 and Y=24.25). Because I often set Z=0 as the top of a work piece (i.e. generally mess about with Z) I’ve left the soft limits for Z as +5” and –5”.

EDIT: Important - these config files were setup in v1.84.001 of Mach3. It would appear that v2.0.009 works sufficiently differently that the settings will be incorrect. Make sure you read the later posts in this thread for details.

I did try to increase the axis speeds, and got to 265ipm, which works, but the control box seemed to keep cutting out, so I’ve left them at 200ipm.

I’ve also attached a metric version – where I’ve redone the motor tuning, limits and home values to mm numbers close to their inch equivalents. This looks OK, but for some reason the soft limits don’t seem to have any affect (the machine will bump into the X+ and Y- limits). I’m not yet sure if this is a Mach bug, or something I’ve done wrong.

Any comments welcome...
« Last Edit: November 14, 2006, 12:56:12 PM by sploo »

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: K2 KG3925 settings for Mach3 here
« Reply #1 on: November 11, 2006, 07:43:19 PM »
Hi, Sploo

Your MM XML

Looks like your Config, Home & SoftLimit's are set to AutoZero, Unchecked these and check that Home Neg. are set properly.

Doesn't look to me that your table is X 100 MM  by Y 1000 MM and Z 40, -40 is corect may be my eye's though..

Nice looking Router

Thank's, Chip
« Last Edit: November 11, 2006, 07:52:44 PM by afn09556 »

Offline sploo

*
  •  13 13
    • View Profile
Re: K2 KG3925 settings for Mach3 here
« Reply #2 on: November 12, 2006, 05:06:42 PM »
Looks like your Config, Home & SoftLimit's are set to AutoZero, Unchecked these and check that Home Neg. are set properly.

Hi Chip,

I think that these settings are OK. Only the numbers differ from the Imperial version, and, checking the Mach doc (section 5.6.1.2) it indicates that ticking the Auto Zero boxes means that, when homed, the axis DROs are set to the values in the Home Off. boxes (rather than all zero's). This is what I want, as the home switches on my machine (and my configuration) are located at X=0, Y=24.25"/615mm, Z=0.

Doesn't look to me that your table is X 100 MM  by Y 1000 MM and Z 40, -40 is corect may be my eye's though..

Yea, that isn't the right values. From which dialog box are you reading them? I've entered the right values in all the boxes I could find.

Nice looking Router

Many thanks. The only thing I've actually cut with it yet is the holes for hold downs in the tabletop, but so far it's looking pretty good.

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: K2 KG3925 settings for Mach3 here
« Reply #3 on: November 12, 2006, 07:44:04 PM »
Hi, sploo

MM.XML

Your comment: (This looks OK, but for some reason the soft limits don’t seem to have any affect (the machine will bump into the X+ and Y- limits). I’m not yet sure if this is a Mach bug, or something I’ve done wrong.)

In config, Home Limits, the auto zero Checked, Bypasse's the limit switches and doesn't show the Gray shaded lines for your soft limit's on the view screen. Thought you sed your switche's were being over-ridden

(Yea, that isn't the right values. From which dialog box are you reading them? I've entered the right values in all the boxes I could find.)

I was looking in the Config, Home Limit's Page, Soft Min, Max.

Just my Thought's, Chip

Offline sploo

*
  •  13 13
    • View Profile
Re: K2 KG3925 settings for Mach3 here
« Reply #4 on: November 13, 2006, 05:08:29 PM »
Hi Chip,

What version of Mach are you using? I've got Mach3 v1.84.001 installed.

I'm not aware of any gray shaded lines on the display, and I have enabled the Tool Boundaries tick box in the ToolPath config. Is it not shown in this version?

I've attached screen grabs of the home/limits page for both my imperial and metric versions. The metric setup was done by multiplying the inch values by 25.4 and choosing a sensible close round value. Not sure why you're getting the 100/1000/40/-40 values, but I guess it would be good to get to the bottom of it.

Any chance you could post some screen dumps?

Cheers.
« Last Edit: November 13, 2006, 05:11:17 PM by sploo »

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: K2 KG3925 settings for Mach3 here
« Reply #5 on: November 13, 2006, 08:55:41 PM »
Hi, sploo

Using 2.0.009 the gray boundaries were added somewhere in the 190.0?? version.

The values were in Your metric.XML I downloaded they don't mater, I see your metric values in your post now.

With Auto Zero checked it ignores the limit switche's, on the Diagnostic you should Babel to see them work.

Hears a screen-shot with switche's enabled, auto turned off.

Hope this Helps, Chip

Offline sploo

*
  •  13 13
    • View Profile
Re: K2 KG3925 settings for Mach3 here
« Reply #6 on: November 14, 2006, 12:03:53 PM »
I've just downloaded v2.0.009 and installed it on a spare PC. I started it up and checked both the metric and imperial versions of my files. One word (or, rather, smiley) :-  :o

Mach opens up a dialog box and tells me it's converted some of the Mach2 tags (Mach2 tags in a config that's come from Mach3 ???), anyway, it warns that only the estop settings (and motor tunings) have been converted.

In other words, if you're using v2.0.009 and use the xml files I posted, the port/pin and home/limits settings bare absolutely no resemblance to what they should be.

So...

1) If you are using the xml files I posted, only use them with Mach3 v1.84.001 (perhaps some later versions will work?)
2) Should I update my installation to v2.0.009? I could manually redo all the settings, but is it worth going to this version?

Hood

*
Re: K2 KG3925 settings for Mach3 here
« Reply #7 on: November 14, 2006, 02:38:12 PM »
When Mach asks to update your Mach2 tags choose No and you shouldnt have a problem. Also you wont be asked again until the next time you update. I have been meaning to bring this up but keep forgetting.
Hood

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: K2 KG3925 settings for Mach3 here
« Reply #8 on: November 14, 2006, 03:01:25 PM »
Hi, Sploo

(Mach2 tags in a config that's come from Mach3 Huh) got the same thing hear.

1. I don't have a router like your's gust trying to help with the Home switch over run.
2. Mach3R2.0 has lazyCam, bundled with it, it's a stand alone program you can use with 184.001, different DXF, Image importer to generate Gcode you can copy it to your Mach3R184.001.

Ver. 2.0 has gray softlimit's, transparent bottom of drawing and quite a few improvement's.

Save / copy your existing .XML's to a different folder for safe keeping along with the install package for 184.001.

Install it and give it a try or if 184.001 is working fine just give LazyCam a try. ?

Just some thought's, Chip 

Offline sploo

*
  •  13 13
    • View Profile
Re: K2 KG3925 settings for Mach3 here
« Reply #9 on: November 15, 2006, 08:03:37 AM »
Hood - I've just tried bringing in the original XML files and choosing not to convert - and, yes, the settings looks correct (and you do get the gray soft limits displayed). Thanks.

Chip - I think I'll try to get some stuff cut before I change version, but I will try it at some point. I did have quite a bit of difficulty getting the machine to move - taking an original config file and changing the port/pin values etc. didn't work. I only succeeded when I based my changes on Zealous' file, so I'm not 100% sure that moving to the latest version will leave me with a working setup until I try it.

On the same subject - I found last night (with help from others) that the files I posted have had the IJ mode (in Config->State) set to absolute, when it really should be incremental. Not something I'd changed, but it causes issues with SheetCAM + Mach.

The problem is that none of this fixes the original problem - that the softlimits don't seem to work on my metric config in v1.84.001! Oh well, it's not the end of the world...