Hello Guest it is November 16, 2019, 04:48:04 PM

Author Topic: somethings keeps getting reversed  (Read 4962 times)

0 Members and 1 Guest are viewing this topic.

somethings keeps getting reversed
« on: December 21, 2010, 04:03:37 PM »
I am using smoothstepper with Mach3.
When things work it is working PERFECTLY!!!!
 But when it messes up it messes up big. The people that make and support smoothstepper are convinced it is not smoothstepper.

As a job is cutting for no reason and with no warning - It just reverses the signal going to the motors somehow. All the sudden it will just complete cut out a mirror opposite of the path it is cutting.

Any ideas what I need to do to fix this?
Thanks

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: somethings keeps getting reversed
« Reply #1 on: December 21, 2010, 04:36:50 PM »
Can you attach your xml and some code that goes wrong and I will see if I can simulate.
Also does the toolpath and the DRO follow the axis when it does its reversal?
Hood
Re: somethings keeps getting reversed
« Reply #2 on: December 21, 2010, 04:55:03 PM »
Attached are the gcode files that I open in Mach3. The outline file has done this more than once and it has happened at random on the others.

The display in Mach3 looks like the job is going normal. In Mach3 nothing looks wrong but when you look at the work it is going the wrong way.

Another question -
Why would the flashing reset button trigger in the middle of a job?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: somethings keeps getting reversed
« Reply #3 on: December 21, 2010, 05:00:01 PM »
Can you attach your xml as well, it is the file that holds your config and that way I can use it to simulate things here with the same setup you have.

Regarding the E-Stop, it sounds like you may be having noise issues, I will have a look at your settings of the SS at the same time when I load your xml to see if there is any problem there.
Hood
Re: somethings keeps getting reversed
« Reply #4 on: December 21, 2010, 05:06:00 PM »
Here is my XMLS file.

What do you mean by noise issue?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: somethings keeps getting reversed
« Reply #5 on: December 21, 2010, 05:26:47 PM »
By noise I am meaning electrical interference affecting  your signal wiring. Had a look at your xml, you dont have any filtering set in the SS config page, it may be your problem of both problems. Try setting values of 10 for each of the filtering entries and see if it helps.

Hood
Re: somethings keeps getting reversed
« Reply #6 on: December 21, 2010, 05:30:48 PM »
Thanks Hood!

Another question - what is filtering and how do I change it?

Thanks!!!
Re: somethings keeps getting reversed
« Reply #7 on: December 21, 2010, 05:31:28 PM »
For when things work it works great. I have been posting some pictures here:
http://celticmachining.blogspot.com/
Re: somethings keeps getting reversed
« Reply #8 on: December 21, 2010, 05:35:20 PM »
I found the filtering option under the smooth stepper options. Not sure what value is supposed to be there when not "0"??

Thanks

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: somethings keeps getting reversed
« Reply #9 on: December 21, 2010, 05:41:21 PM »
If you go to the Plugin tab in Mach then to SmoothStepper Config you can set the filtering there. Basically it just tries to filter out and noise you are getting so that the SS ignores it.

Looks like you have been doing some good work :)
Hood