Hello Guest it is May 11, 2021, 06:43:30 PM

Author Topic: Upgrade from 1.84 on lathe  (Read 10759 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Upgrade from 1.84 on lathe
« Reply #30 on: December 30, 2010, 02:37:31 PM »
Oh and disabl;e backlash and see if that helps your other probs, it will at least let you know whether the backlash is the culprit and needs twaked.
Hood

Offline DAlgie

*
  •  314 314
    • View Profile
    • Algie Composite Aircraft
Re: Upgrade from 1.84 on lathe
« Reply #31 on: December 30, 2010, 03:30:30 PM »
Spindle is a fixed gearbox setting, 8 speeds, with one pulse per revolution. On the pulses per revolution, if I bring up the calibrate spindle page, it shows the pulses per revolution as 1, and it says "Zero if one per rev", and there is a box there with 1 in it. It won't let me change that to a zero for some reason. How do I change that to a zero as it should be?

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Upgrade from 1.84 on lathe
« Reply #32 on: December 30, 2010, 03:44:49 PM »
Ok so do you call a M3 from Mach

Hood

Offline DAlgie

*
  •  314 314
    • View Profile
    • Algie Composite Aircraft
Re: Upgrade from 1.84 on lathe
« Reply #33 on: December 30, 2010, 03:53:48 PM »
Yes, Mach starts the spindle.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Upgrade from 1.84 on lathe
« Reply #34 on: December 30, 2010, 03:55:06 PM »
Ok  so not what I was thinking then, if you attach your xml I will have a look see if I can find a problem if you wish.
Hood

Offline DAlgie

*
  •  314 314
    • View Profile
    • Algie Composite Aircraft
Re: Upgrade from 1.84 on lathe
« Reply #35 on: December 31, 2010, 09:52:10 AM »
OK, XML duly attached, thanks Mr Hood.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Upgrade from 1.84 on lathe
« Reply #36 on: December 31, 2010, 10:15:24 AM »
Only thing I see that could be a problem is the Index debounce, I am sure however you said you had tried all sorts there.
From my experience(with the PP) it usually can only be set low, I used to use zero but may depend on your opto and wiring but I would think 5 or 10 max.

One other thing regards the backlash, do a search here, I think its Rich who usually advises on a rule he uses. Might be the shuttle on General config page needs changing.

Hood

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile

Offline DAlgie

*
  •  314 314
    • View Profile
    • Algie Composite Aircraft
Re: Upgrade from 1.84 on lathe
« Reply #38 on: December 31, 2010, 02:13:29 PM »
Worked perfect on the index debounce setting, even 10 there would screw it up, zero was what it needed, thanks mr Hood! I will look into the backlash wierd speed thing next, happy New Year!

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Upgrade from 1.84 on lathe
« Reply #39 on: December 31, 2010, 02:19:07 PM »
Good news, hopefully the backlash settings Rich uses will sort you out :)
Hood