Hello Guest it is June 20, 2019, 04:09:02 PM

Author Topic: Simple (I am guessing) hook up that has me stumped  (Read 1550 times)

0 Members and 1 Guest are viewing this topic.

Simple (I am guessing) hook up that has me stumped
« on: November 28, 2010, 02:42:20 AM »
I'm sure this is a simple process but it has me hung up.

What I am needing to do is tap the 5v source that runs my break out board, hook that to a pin and then configure Mach3 to look for a high signal on that pin (the high signal would indicate that power is applied to the drivers and the break out board).

I want o do this as my drivers and break out board are powered separate form my mach3 computer and the machine itself and its quite aggravating to set the machine up in the evening then shut power off to the drivers/Break out board only to come back in the following day and hit jog on the Mach3 computer and loose the reference points (IE jogging in Mach3 without the motors physically moving on the machine). Mach3/machine was originally hooked up to fault when the driver/Break out board were without power. Since then we moved the machine to a new location one person did the tear down and another did the rewiring after the move and that's the one "feature" that was never hooked back up to work as before.


Thanks in advance for any assistance in getting this hooked/configured back up,
~T

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: Simple (I am guessing) hook up that has me stumped
« Reply #1 on: November 28, 2010, 07:36:13 AM »
You could set up as an input then use the macropump to pop up a message on screen if the input is not active.
VB for it would go something like this

If Not IsActive(Input1) Then
MsgBox("drives are disabled, please enable")
End If


Hood