Hello Guest it is July 16, 2019, 11:13:24 PM

Author Topic: Bug in formulas  (Read 7069 times)

0 Members and 1 Guest are viewing this topic.

Re: Bug in formulas
« Reply #20 on: December 14, 2010, 10:30:23 PM »
hi- I am brand new to cnc and Mach 3.  I am having trouble with the formulas.  Moderator, if this should be a new thread let me know.  The machine is custom built. It has two axis.  No Z.  It is going to be a portable cnc plasma.  For now it is proof of concept phase.  A axis is rotate(rotary table), and B axis is linear on the  on top of the rotary table. It looks like a "banjo". The tool is  held on the B axis and is constrained to a line that passes through the center of the rotary table.
Right now it is just drawing  with a marker on paper.

I want it to run on standard  x y gcode.   My formulas are as follows.

A= arctan(y/x)*57.2957795
B=((x^2)+(y^2))^.5
It tests fantastic on the test feature on the formulas window.
All four axis (X Y A B) home at the rotary table's center.
I have been using very simple X Y gcode.

A note on something I read in the thread. I found the formulas work in MPG, Gcode, and STEP.  Not on Hot keys and buttons.

Here is the problem. My test is a 5"square. I have drawn it at many locations on the table. It is consistent does not lose steps.  It draws a complete square and it closes it.  The size  of the square is good and the corners  form a perfect square. The lines that connect the corners are arcs.  

If you draw a circle,  the machine will drop the  A and B axis completely.  

I think my formula,s scaling and backlash(lack of) are good, The program  seems to get it goofy or drop it completely. I have the problem at all feed rates.  It it processing power on my computer?
Any thoughts would be helpful.
Adrian