Hello Guest it is January 23, 2020, 08:49:37 AM

Author Topic: Problems with Circles  (Read 1747 times)

0 Members and 1 Guest are viewing this topic.

Offline CJCNC

*
  •  24 24
    • View Profile
Problems with Circles
« on: November 25, 2010, 08:33:42 PM »
Hi all,

I seem to be having trouble with circles. 

I am using solidworks with visual mill as my cam and I have also used Bobcam and the same problem always happens which leads me to believe that there is something wrong in Mach 3.

I have a part with a series of circles from 4mm to 6mm in diameter followed by a profile cut.  The circles that are being shown on the screen are crazy big.  Probably 130mm  I don't know what is going on or what setting I am doing wrong.  The profile cut seems to be doing well but not the circles for some reason.

Here is the code.  Any help is appreciated

G00 G49 G40.1 G17 G80 G50 G90
G21
(Hole Profiling)
M6 T1
M03 S3200
G00 Z1.5875
X133.2482 Y87.8833
G01 Z-3.0000  F41.1
G17
G02X132.4232I-0.4125J0.0000 F25.4
X133.2482I0.4125J0.0000
G00 Z1.5875
X126.1035 Y81.4367
G01 Z-3.0000  F41.1
G02X124.2785I-0.9125J0.0000 F25.4
X126.1035I0.9125J0.0000
G00 Z1.5875
X118.9587 Y74.9902
G01 Z-3.0000  F41.1
G02X116.1337I-1.4125J0.0000 F25.4
X118.9587I1.4125J0.0000
G00 Z1.5875
X13.0379 Y33.7452
G01 Z-3.0000  F41.1
G02X11.7129I-0.6625J0.0000 F25.4
X13.0379I0.6625J0.0000
G00 Z1.5875
X20.6136 Y26.9383
G01 Z-3.0000  F41.1
G02X18.7886I-0.9125J0.0000 F25.4
X20.6136I0.9125J0.0000
G00 Z1.5875
(Contour Profiling)
Z3.0000
X26.9318 Y-0.3114
G01 Z-6.0000  F41.1
X26.7557 Y-0.1688  F25.4
X26.4504 Y0.1664
X-1.2544 Y35.6268
X-1.5392 Y36.0654
X-1.7435 Y36.5468
X-1.8612 Y37.0563
X-1.8885 Y37.5785
X-1.8248 Y38.0976
X-1.6719 Y38.5976
X-1.4345 Y39.0636
X-1.1198 Y39.4812
X-0.7374 Y39.8379
X7.1427 Y45.9945
X7.5341 Y46.2537
X7.9612 Y46.4486
X8.4134 Y46.5746
X8.8797 Y46.6284
X9.3488 Y46.6089
X9.8090 Y46.5164
X10.2492 Y46.3533
X10.6585 Y46.1235
X34.7258 Y30.0133
X42.8026
X135.2535 Y100.3739
X135.6662 Y100.6377
X136.1162 Y100.8309
X136.5917 Y100.9482
X137.0799 Y100.9866
X137.5679 Y100.9451
X138.0426 Y100.8248
X138.4914 Y100.6288
X138.9023 Y100.3624
X139.2645 Y100.0327
X146.0844 Y92.7191
X146.4064 Y92.3070
X146.6519 Y91.8453
X146.8135 Y91.3480
X146.8863 Y90.8301
X146.8680 Y90.3075
X146.7593 Y89.7960
X146.5634 Y89.3112
X146.2863 Y88.8677
X145.9364 Y88.4791
X50.8604 Y-0.1807
X50.5093 Y-0.4620
X50.1201 Y-0.6876
X49.7015 Y-0.8525
X49.2630 Y-0.9529
X48.8144 Y-0.9867
X28.8144
X28.3623 Y-0.9524
X27.9206 Y-0.8504
X27.4993 Y-0.6830
X27.1080 Y-0.4541
X26.9318 Y-0.3114
G00 Z3.0000
M5 M9
M30

Re: Problems with Circles
« Reply #1 on: November 25, 2010, 08:48:04 PM »
This is most likely due to your "IJ Mode" under "General Config" being set to Absolute, when it should be Incemental.

Offline CJCNC

*
  •  24 24
    • View Profile
Re: Problems with Circles
« Reply #2 on: November 25, 2010, 09:01:22 PM »
Thank You sooooo much..  this has been bugging me for days now and you finally helped me solve the problem.. 

Thank you