Hello Guest it is August 17, 2019, 11:35:35 AM

Author Topic: Spindle control  (Read 2083 times)

0 Members and 1 Guest are viewing this topic.

Spindle control
« on: November 01, 2010, 10:21:31 PM »
I am having a problem getting spindle control to work.
I am using pin 14 on LPT 1 mapped to Output 1 and have M03 and M04 set to Output 1.
This is on a Bridgeport BOSS 8 so spindle control enables the spindle or stops the spindle.
No mater what I do the spindle is enabled as long as the computer is powered up.
If I shut the computer down the spindle stops. LPT 1 pin 14 is connected to the spindle enable pin that works under the AHHA control system.
I am at a loss as to what to do next.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Spindle control
« Reply #1 on: November 02, 2010, 03:03:36 AM »
Can you attach your xml please.
Hood

Offline Tweakie.CNC

*
  • *
  •  7,882 7,882
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Spindle control
« Reply #2 on: November 02, 2010, 12:12:08 PM »
I presume you have tried Output#1 active low checked / active low unchecked to see if this cures it ? (also check that no other outputs are mapped to pin 14).

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Spindle control
« Reply #3 on: November 02, 2010, 07:47:25 PM »
I have some other problems also so I think I will quit trying to convert from the AHHA system and do a complete rewire using a BOB.