Hello Guest it is September 26, 2020, 05:27:01 AM

Author Topic: Spindle Pulley setup, Reverse  (Read 2146 times)

0 Members and 1 Guest are viewing this topic.

Offline thosj

*
  •  411 411
    • View Profile
Spindle Pulley setup, Reverse
« on: October 23, 2010, 01:45:45 PM »
I have a BP clone on Mach. I've had it running for 19 months or so. I currently run a SmoothStepper and the Mach3 dev version, 3.043.022 and MSM screen, but I can also run 1024 screen on the dev version.

I've had my spindle setup for ages and it's been OK on a Hitachi VFD 0-10v, PMDX-125/107, PWM spindle control. I have a step pulley head and have 8 pulleys setup, 1-4 for low gear, reverse, 5-8 for high hear, not reverse. I've never run in one of the low pulley speeds until today when I was setting up an index sensor on the MOTOR PULLEY and setting ratios in the spindle pulley setup, which I got working well BTW. I noticed that for pulleys 1-4, no matter if the Reverse is checked or not, the spindle doesn't run the right direction. MDI M3, click Start Spindle, or hit F5, in pulleys 1-4 it starts in reverse. M4 starts it forward. It works as it should in pulleys 5-8 where reverse is NOT checked. I have not tried checking reverse in pulleys 5-8!

Am I missing a setting somewhere that the spindle can't be reversed with the spindle pulley settings or is there some other issue? Is it perhaps the Dev version? Or the SmoothStepper? I don't remember reading anything like this in the past, but I've never had a need as I never run in the lower pulleys. I THINK I remember it working OK way back when I set the machine up, but I was on a CNC4PC C23 and step/dir control, still with SS and same VFD.

Tom

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Spindle Pulley setup, Reverse
« Reply #1 on: October 23, 2010, 02:47:36 PM »
I have recollections of seeing someone mention this problem or one very  similar, cant really remember where but could have been the Yahoo group. I think Brian fixed it up but maybe the Dev version does not have it fixed so worth trying the lockdown to see.
Hood