Hello Guest it is March 23, 2023, 01:12:44 AM

Author Topic: Smoothstepper problem when spindle is on  (Read 12048 times)

0 Members and 1 Guest are viewing this topic.

Offline DMBGO

  •  201 201
  • Time is the same in a relative way
    • View Profile
Re: Smoothstepper problem when spindle is on
« Reply #10 on: October 23, 2010, 03:40:17 AM »
I think I have the answer to this common issue, here is a copy of the rather detailed saga that I posted on the yahoo group.

I think I may have the answer to this, please skip down to the last few paragraphs if you are not interested in why it fails, but would prefer how to fix it.


From what I’ve read, Jeff and many others have spent a lot of time solving electrical noise related issues with the smooth stepper. I have just recently gone through a trial and error resolution of this same problem, although perhaps issues were more repeatable?


From the day that I received my smooth stepper I could consistently make the SS stop responding by starting my lathe motor, which is on an electrically noisy VFD., so I read up on the forums about the subject and started trying things that others had recommended, in what I hoped was a systematic manner.


When I first experienced issues I had the SS just sitting on my electronics workbench, unprotected, about 15 feet from the vfd.


The things that I had read about and decided to try were:


1/ Mount the smooth stepper and the BOBs into their own chassis, with a separate power supply (other than the PC’s power).


2/ Use only shielded cables and connect the shields to the earthed chassis at the controller end away from the lathe.


3/ use a separate power supply for the break out boards and power the smooth stepper from the usb cable.


4/ Number 3 test reversed.


5/ Put the smooth stepper into a separate grounded metal enclosure (powered from PC).


6/ Ground the smooth stepper via its grounding jumper and a metal post to the controller chassis.


7/ Number 6 test but with the break out boards grounded as well.


8/ Isolate the smooth stepper from ground completely using plastic standoff mounts but ground the breakout boards.


9/ Number 8 test, but also isolate the BOBs from ground as well.


10/ Fit an EMI filter to the input of the VFD.


11/ Fit ferrite rings to the cables between the bobs and the smoothstepper.


The fact that I made it through all of these tests may give some clue as to the fact that none of these fixed the problem. Occasionally the smooth stepper would continue to function for a few seconds after starting the lathe motor, causing a quick indrawn breath, but it would inevitably stop responding seconds afterwards.


I was continually assailed by doubts while carrying out the above experiments, since I had no way of telling if some of the steps were improving things, or making them worse – I could have been trying the fix combined with something else that was stopping the fix from taking effect. I kept thinking that perhaps the answer was a particular combination of the above steps and I tried a fair few combinations.


While carrying out my connecting things to ground / isolating from ground experiments, I noticed that when the PC was off, but with the usb cable plugged into both the PC and the smooth stepper and I measured between the shield on the smooth stepper’s usb connector and chassis ground on the controller the meter behaved as if I was measuring across a capacitor (I probably was). If I unplugged the usb cable from the smooth stepper I measured about 7 Meg ohms between the shield and ground. This was with the smooth stepper isolated from ground via plastic standoffs.


When I turned on the power to the PC, with the USB cable connected, the smooth stepper’s usb shield was immediately connected to chassis ground on the controller back via the PC, and then through the ground wire in the wall.


At this point I had a light bulb moment I had read in other places on the net about VFDs putting EMI spikes back into the ground circuit of the building, and the experiments with isolating the smooth stepper from ground completely were meant to eliminate this as a cause of the lockups, but I didn’t know that the usb shield was being connected to ground via the PC.


I had read in a post somewhere where another smooth stepper user had fixed his lockups by swapping USB cables, so I decided to try a few different cables to see what happened. (I have quite a few usb cables around because I work in IT). The very first cable I tried eliminated the problem completely. The smooth stepper went from locking up within 3 seconds every time I started the spindle motor, to not locking up at all. In fact I could even sit the controller chassis on top of the VFD with the smooth stepper inside and start the spindle without it locking up.


This all happened about 3 weeks ago since then I haven’t had a single lockup with the smooth stepper. This afternoon I decided to find out what the difference was between the working usb cable and the one that was causing the lockups. I plugged the cables into the PC and measured between the usb signal pins and the shield on the usb cable, the only difference I could find between the two cables was that the one that worked reliably had about 1.4 ohms resistance between the ground pin and the shield, and the one that failed reliably, had only 0.3 ohms resistance (this resistance was being measured back through the PC).


I suspect that the cable that was failing may have been the better quality cable. Both cables had no connectivity between the shield and the usb ground pin when the cable was unplugged and the shield had continuity in both of the cables.


Any way to end a very long story, I decided to see if I could make the smooth stepper work with the cable that had always failed, so first I tested it again on the smooth stepper and was able to instantaneously cause lockups by starting the spindle. I then put the same cable in the vice and carefully hack sawed through the metal case around the plastic plug on the end of the cable where it plugs into the smooth stepper. I then removed the metal shield from that end of the cable and plugged the plastic part of the connector into the smooth stepper. It worked flawlessly!


I even bypassed the line filter on the vfd to reintroduce as much electrical noise as possible, with no problems.


I am now quite convinced that this was the cause of my issues, and also I strongly suspect the cause of the same issues that many others have also experienced.

I suspect that a small design change to the smooth stepper would eliminate this lockup problem almost completely. It would be worth while, since otherwise this is a very good product.


I hope I haven’t bored the pants off you all with this.




David M


Offline Dan13

  •  1,208 1,208
    • View Profile
    • DY Engineering
Re: Smoothstepper problem when spindle is on
« Reply #11 on: October 24, 2010, 03:19:48 AM »
Hi David,

Very interesting findings! Thanks for the post.

I am curious what's the explanation though.

Re: Smoothstepper problem when spindle is on
« Reply #12 on: November 07, 2011, 12:38:40 PM »
USB cables are not all the same.
USB cables for mice and keyboards tend to be not shielded.
Other USB cables say they are USB 2.0 rated, but unfortunately may not be manufactured to the USB 2.0 specification.
Measuring the resistance between the metal shell at each end is a reasonable method to determine if there is a full shield or not.
A lower resistance for a given length of cable would be indicative of a better shield.
A foolproof method is to purchase two or more cables at the same time from the same place, and dissect one to determine if there is a shield and what type.
The best shield has both a metal foil and a wire braid.
Next would be just a metal foil with a drain wire.
The worst would just a single wire, (which really is not a shield at all)