Hello Guest it is July 19, 2019, 01:25:21 PM

Author Topic: Why Mach3 "Pause" for split second on every G-code line ?  (Read 4725 times)

0 Members and 1 Guest are viewing this topic.

Why Mach3 "Pause" for split second on every G-code line ?
« on: October 15, 2010, 08:33:16 PM »
When I cut circle or Z radial cut, I always get Pause for 1/50 second before reading the next line ?

I create the G-code from Mastercam X3, I already install the Post Processor.

I check the Mach3 setting, but nothing wrong... or I miss something ?



Help
Cal

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Why Mach3 "Pause" for split second on every G-code line ?
« Reply #1 on: October 15, 2010, 09:09:10 PM »
You are probably in Exact Stop mode. Try using CV mode.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Why Mach3 "Pause" for split second on every G-code line ?
« Reply #2 on: October 15, 2010, 09:56:26 PM »
is that on general Logic Config menu ?
how to do CV mode ?

Cal
« Last Edit: October 15, 2010, 10:02:22 PM by calico »

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Why Mach3 "Pause" for split second on every G-code line ?
« Reply #3 on: October 15, 2010, 10:25:22 PM »
General Config, or use G64 at the start of your code.

G61 to change back to Exact Stop.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Why Mach3 "Pause" for split second on every G-code line ?
« Reply #4 on: October 15, 2010, 11:09:51 PM »
I add G64 at the start it works great.
but how to change the Gen Logic Menu setting to make it works ?

I try to check un check the "Stop CV on angles, uncheck and check the G100 still dosn't work.
can you specify the parameter which one should be check or not ? and what degree should I put ?


now what it the different if I use CV mode or Stop mode ?
I only cut wood (router).

I really appreciate our help
Cal

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Why Mach3 "Pause" for split second on every G-code line ?
« Reply #5 on: October 15, 2010, 11:18:29 PM »
This mught give yousome more information.
http://www.machsupport.com/docs/Mach3_CVSettings_v2.pdf
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Why Mach3 "Pause" for split second on every G-code line ?
« Reply #6 on: October 16, 2010, 12:32:40 AM »
Yes I read that before, but I can not set on the general logic config to get the same result like if I add G64.

what I want is getting the result like G64 but with changing the parameter on the General Logic Config setting.
I still get the stop motion whatever I change the setting.


Cal

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Why Mach3 "Pause" for split second on every G-code line ?
« Reply #7 on: October 16, 2010, 07:26:11 AM »
Are you changing this? You want to select Constant Velocity, but turn off the other options. Here's how mine is set.

If you get excessive corner rounding, you can try setting the angle setting to 89 or 90 and enabling it. Also turn off the 2 CV options on the settings page, CV distance and CV feedrate.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Why Mach3 "Pause" for split second on every G-code line ?
« Reply #8 on: October 16, 2010, 10:36:20 AM »
the other way to do it is to put G64 in your initialisation string, also under general config.
Re: Why Mach3 "Pause" for split second on every G-code line ?
« Reply #9 on: October 17, 2010, 10:08:14 PM »
Guys, it's loud and clear.
it works well like G64.
thank you

great support and helps.


Regards
Cal