Hello Guest it is June 24, 2019, 05:54:50 AM

Author Topic: Spndle Calibration  (Read 1719 times)

0 Members and 1 Guest are viewing this topic.

Spndle Calibration
« on: September 25, 2010, 12:23:14 PM »
I am having a lot of issues with the spindle calibration on my MaxNC lathe. The Auto calibrate feature does not seem to work properly with my setup.

Does anyone know where the calibration data is stored? I tried looking at the turn XML files but I can not find anything in there. I was expecting some sort of table the had PWM to Spindle RPM values. I also looked in the registry and found nothing there as well.  was hoping a table existed that I could edit manually to correlate PWM outputs to my spindle rpms. Does anyone know the procedure for a manual calibration?

My spindle will not run slower than 300 RPM and has a max rpm of 3000. The auto calibrate does weird things when the spindle is not moving at the low speeds so I thought I would set the pulley speed configuration to 300 to 3000. When I do this the auto calibrate will not even work. I get errors saying spindle speed to low, using minimum and the program does not perform the sweep.

I was using version 2.63 so I tried and upgrade to 3.042. Now Mach3 can not read my index pules. No matter what the spindle is running at it always indicates a spindle speed of 148rpm. Does anyone know why this may be?

Thanks


« Last Edit: September 25, 2010, 12:26:01 PM by slammers »

Offline jaja

*
  •  68 68
    • View Profile
Re: Spndle Calibration
« Reply #1 on: September 30, 2010, 06:46:03 PM »
Hy Slammers
About your index pulses: could it be caused by the fact that you've got more then one pulse per revolution?
For as far as I know mach 3.042 only works with an index pulse, which is one pulse per revolution.
Look at this PDF for a very good explanation
http://www.cjh.com.au/PWM%20Spindle%20Control%20using%20Mach3.pdf

gr jaja