Hello Guest it is April 13, 2021, 04:32:24 PM

Author Topic: Verify (MDI menu) Crashing Z Axis Limit....  (Read 2616 times)

0 Members and 1 Guest are viewing this topic.

Verify (MDI menu) Crashing Z Axis Limit....
« on: September 26, 2010, 12:37:24 PM »
Greetings all.   i hope this will be a easy fix for someone....      i am still in the learning / practicing phase of Mach3 and lately i have been "dry" running a drill program that i wrote;  then checking for errors using the "verify" button on the MDI page.   most of the time it takes out the Z axis limit switch before registering the referencing function so i have to re~home and start over with my tests.   i have tried taking down the feedrates prior to hitting verify,, thinking its a speed issue, but it still continues.   what i dont think i have set right is the safe Z & homing slow zone settings.   tried searching on here and google for help with these but nothing found.   also when i verify, the x & y axes feed about 31% of rapid while the z feeds at 100%....   kinda frustrating, thanks in advance!!

Bill

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Verify (MDI menu) Crashing Z Axis Limit....
« Reply #1 on: September 26, 2010, 12:46:55 PM »
What do you have for the homing speed % for the Z axis? Its Config menu the Homing and Limits.
But I am not sure why it would only do this in Verify if its fine with normal hoiming.
Hood
Re: Verify (MDI menu) Crashing Z Axis Limit....
« Reply #2 on: September 27, 2010, 10:50:33 AM »
thanks Hood, i have the Z set same as X & Y for homing speed, 22% ~ it doesnt crash if i manually slow the feed override down prior to verifying, but kinda a pain, ya know?   and yes all 3 axes are fine while homing, moving nice and slow....    thanks, bill

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Verify (MDI menu) Crashing Z Axis Limit....
« Reply #3 on: September 30, 2010, 04:58:19 PM »
Just bumping to the top again.
Have you got any further with this?
Afraid I cant test myself as all my machines all run with the SmoothStepper and verify is done in that rather than within Mach.
Hopefully someone else will do a test to see if they too have issues.
Hood
Re: Verify (MDI menu) Crashing Z Axis Limit....
« Reply #4 on: September 30, 2010, 09:53:36 PM »
Thanks again Hood, no other msgs or postings, but i havent been having the limit out problem, perhaps i have gotten my z error under control which keeps it from blowing thru the limit?  just a thought.   i had some x stalling the other day, which i fixed by re~aligning the screw/bearings and slightly backing off on the acceleration, which i change the same on all 3 axes.....    that might have inadvertantly helped the z issue.   my screw is 1" per rev, so its pretty sensitive driving it with 185 in~oz steppers....   shoulda got 400+ motors!!!     live n learn lol   have a great night, Bill

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Verify (MDI menu) Crashing Z Axis Limit....
« Reply #5 on: October 01, 2010, 03:20:49 AM »
Good to hear you have it sorted so far, hopefully it stays that way. And yes we all live and learn, I have lost count of the times I have wasted money by trying to save a little ;D

Hood