Hello Guest it is November 15, 2019, 02:15:16 AM

Author Topic: Steppers sent steps when changing screens  (Read 1924 times)

0 Members and 1 Guest are viewing this topic.

Offline beefy

*
  •  138 138
    • View Profile
Steppers sent steps when changing screens
« on: September 24, 2010, 12:02:36 AM »
 :o
Hi All,

wondering if anybody has experienced this one.

Testing the X and Y axis of my almost finished plasma table. Everything seems to be working fine apart from some steps (always negative) being sent to both axis when I do things like swapping between different screens in Mach or using the tab key to open the jogging window. Mach is not in reset (i.e. reset button is green and not flashing) but the program is not running. This is how I first picked up on it, I could actually hear the motors nudge a tiny bit while everything was still.

The computer is bare bones nothing but Mach installed. Windows XP installed in Standard PC mode. Done the recommended optimisation, killing startup items, etc. I can do a 30 minute program run with the X and Y axis "cutting" a zillion little pieces and the machine arrives back at zero point exactly. Yet simply changing between screens with no program running causes negative steps to be sent to both axis. The digital readouts do not change so every few negative steps sent gets the axis more out of position.

Thanks,

Keith.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Steppers sent steps when changing screens
« Reply #1 on: September 24, 2010, 03:17:32 AM »
Is it a wireless keyboard/mouse? Thats the he only thing I can think of, that you are getting interference that way as it looks like  Mach is not sending the signals or the DROs would show it.
Hood

Offline beefy

*
  •  138 138
    • View Profile
Re: Steppers sent steps when changing screens
« Reply #2 on: September 24, 2010, 04:59:07 AM »
Hi Hood,

the mouse is a normal wired one which plugs into the mainboard. Thing is this problem also happens when the mouse is still and I press the tab key to open the jogging window.

I'm hoping to God it's nothing to do with my plugins. I'm using the MP3000 plugin from CandCNC but I've never heard of anyone getting this problem. Maybe I'll try uninstalling Mach and reinstalling it minus the plugins. If it still happens then at least it's eliminated that possibility.

Keith.

Online Tweakie.CNC

*
  • *
  •  7,993 7,993
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Steppers sent steps when changing screens
« Reply #3 on: September 24, 2010, 05:27:33 AM »
Keith,

Sounds like it could be an electrical noise problem. You could try re-routing your cables clear of your monitor and separating the mains wiring runs from the signal wiring runs.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.