Hello Guest it is December 15, 2019, 12:50:02 AM

Author Topic: problem with z axis  (Read 2091 times)

0 Members and 1 Guest are viewing this topic.

Offline xaco

*
  •  26 26
    • View Profile
problem with z axis
« on: September 15, 2010, 05:14:42 PM »
hi!..or better....HELP!..  I have a problem with z axis when its running at higher feed than 2 ipm! It happens  that every time that z axis should finish moving up or down,the  x or y movement starts before z finished its work,so result is that  edges r cut off when z was going up,or edge is not 90 degrees but rounded when z was suppose to go down and  stop so x or y would continue...
                                                                                                                                                        
i made a 3D model,just a simple wall,0.1 inch high and 0.1 inch thick,and i made g-code for that in artcam..so the tool coming from left approached the wall,stopped,went up,but before it reached 0.1inch in z ,the tool started to move horizontal so it cut the edge(made it rounded)..than tool continued as it should over the wall and it stopped as it should,than it started to move down 0.1inch but again before it reached the end,the tool started to move to right(z still doing its job-so it produced curved edge again).this was happening at feed rate-8ipm and plunge rate-4ipm.it dosnt happen at 2ipm.
                                                                                                     
Than i rewrote those 5 moves of g-code and i loaded them using TEACH mode in mach3,adding 4ipm feed for horizontal and 4ipm for vertical moves as in original g-code. Now for my supp there was no rounded edges ,the z axis would finish its job  before x axis started to spin.                                                                                                                                                                            
anyone have idea whats going on?what can i do to achieve sharp edges  at high feeds ?why its different result when i make  g-code and load it using teach mode?
« Last Edit: September 15, 2010, 05:28:10 PM by xaco »

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: problem with z axis
« Reply #1 on: September 15, 2010, 06:01:45 PM »
Try with a G61 at the start of the code and see if it works, if it does then it is likely due to a fairly slow acceleration. You could try messing with the CV settings on General Config but test out with Exact Stop (G61) first to make sure that is the issue.
Hood

Offline xaco

*
  •  26 26
    • View Profile
Re: problem with z axis
« Reply #2 on: September 16, 2010, 05:30:50 AM »
Try with a G61 at the start of the code and see if it works, if it does then it is likely due to a fairly slow acceleration. You could try messing with the CV settings on General Config but test out with Exact Stop (G61) first to make sure that is the issue.
Hood
Thanks Hood,i wrote G61 in g-code and now its making right angles even at 500mm/min. Can I set this somewhere in settings so i dont need to edit g-code every time?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: problem with z axis
« Reply #3 on: September 16, 2010, 06:09:17 AM »
Ok thats good, it proves that it is because you were using Constant Velocity and your acceleration is too slow to keep up. Constant Velocity is really the preferred mode so it would be best to either try and increase your acceleration or mess around with the angle settings for CV on the General Config page.
CV and ExactStop should really be called from your code so that you know exactly which mode you are in but you can set the default, again its on General Config page.

Hood